Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have looked through many of the questions, and haven't found anything that quite satisfies this problem. I have an ssd hard drive that is bootable from my old computer. It is a standard BIOS, however, I built a new computer with Z87 motherboard that is a UEFI. What I'd like to do is boot from this hard drive without wiping out the hard drive. I've tried booting from legacy mode, doesn't seem to work. Part of the multitude of problems is my partitioning scheme, which is GPT. sdx1 is the btrfs system, sdx2 swap, sdx3 is bios_grub.

I've tried setting the UEFI/BIOS to boot in legacy mode, I've tried turning my swap partition into a Grub EFI boot, I've tried copying the file system onto a new drive installed on the new system. However, copying the information doesn't keep the filesystem or subvolumes intact. I've also tried boot-repair which is when I overwrote the swap space. I'd really rather not start over on a new install, so any other suggested trees to bark up would be appreciated.

For the record, I hate you Microsoft, and ASUS I understand complying with microsoft, but make it optional... I'm really disappointed in that I have to deal with Windows 8 when I have nothing to do with it.

Something I think I could try, but would like to hear from more experienced users. Moving the sdx1 (btrfs /@/@home) partion and opening up a 100 MB partition on the beginning sectors and install efi compatible Grub2 installation. Would it work? How to move a partition?

share|improve this question
    
Btrfs is experimental. Can you successfully EFI boot on a standard EXT4 Ubuntu install ? –  LovinBuntu Oct 19 '13 at 22:51
add comment

1 Answer

First, some EFIs have odd requirements when booting from GPT in BIOS mode. See my Web page on the topic for details. In most cases, setting the boot/active flag on the type-0xEE partition in the protective MBR will fix the problem. Note that you need fdisk (but not the very latest version!) or some other GPT-unaware tool to do this. (The very latest version of parted can also do this, but I don't recall the precise details.)

Second, if that doesn't help, you may be able to install an EFI-mode boot loader on the disk to get the job done. See my Web page on EFI boot loaders for information on what's available and how to install them. GRUB 2 might be fairly easy to install if you can chroot into the system in EFI mode; or you can try installing rEFInd, which you can install manually (not via the Debian package) or after using chroot.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.