Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So, a week ago I installed the latest beta version of Ubuntu Saucy Server in a MacMini using BTRFS as only partition to mount / on it (I know it's not recommended to do this, but it's not the point here) with no problems at all. Everything went just "naturally"...

Now with the released image of 13.10 server, I just can't get any BTRFS partition done from installer. I'm getting a: Can't create filesystem error, whenever I try to create any BTRFS partition, like the 13.10 server final installer can't handle format BTRFS partitions...

  • Am I doing something wrong? Or it's a bug in the installer? Is there anything that I can do to workaround this and get my BTRFS partition set on installation, or I'll need to work this after the installation.

I can just leave some space left and create a btrfs partition later on, with Saucy already installed and proceed to use to LXC (which is my solo purpose to have btrfs), but anyway, why installer can't do btrfs anymore?

share|improve this question

Look for the installer log files.

Maybe it's refusing to mkfs over an existing filesystem; the check and override flag were added to mkfs.btrfs recently.

I know you've fixed it already, but for anyone else, you can use the wipefs command to remove a filesystem signature and make a device available for partitioning (wipefs with no flags is harmless).

share|improve this answer
  1. Find the drive that you want to install the OS on using sudo fdisk -l (in this case it was /dev/sda1 & /dev/sda2)
  2. Run wipefs with -a modifier on all of the partition on the drive that you want to install the OS on.
  3. The command should look like this sudo wipefs -a /dev/sda1 && sudo wipefs -a /dev/sda2

  4. Run the installer after you've done the wipefs.

This process has worked for me to install Ubuntu 13.10 with btrfs.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.