Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Never had a problem with Maverick, always very fast. I upgrade to Natty and the graphics seem to be very lagged. CPU, load, and memory usage is low, all graphics are choppy and lagged though. I have the proprietary driver installed and everything.

Alt-Tabbing takes 3-5 seconds for the dialog to popup, zooming in with compiz zoom makes things very slow. I never had any of these problems with 10.10

share|improve this question
1  
Have you tried it without fglrx? –  Jorge Castro Apr 23 '11 at 16:23
add comment

4 Answers

Hey, if you install compizconfig you can try unchecking the V-Blank in general options, as in the open-source ATI driver in natty there is already V-sync activated. It did the trick for me so you can try it

share|improve this answer
add comment

In ubuntu 11.04 the setting is located on ccsm>OpenGL>Sync to VBlank. When fglrx is enabled, this should be unchecked otherwise performance is sluggish and slow.

share|improve this answer
add comment

try the latest amd-ati-catalyst-114

share|improve this answer
add comment

Had the same problem, but using this info solved it: http://www.linuxinsight.com/your-ati-radeon-very-slow-on-xorg-x-server-1.3.html Now my Ubuntu is snappy beyond my imagination

share|improve this answer
2  
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Eliah Kagan Jul 13 '12 at 18:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.