Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 12.04 64bit installed/full updated and have noticed that I can only play 1080p youtube videos properly on full screen. All other resolutions, 480, 720, 1440 etc do not go into full screen properly. Please have a look at the attached images. You will notice that only the 1080p video has the video control bar right at the bottom with a respectable text size. All other videos don't have the video control bar right at the bottom on the screen, and the control bar text is too small.

I've had this problem for ages, but finally decided to ask about it.

480p: Notice the bottom control bar, it's not at the bottom on the screen and the video has borders on the sides: 480p

720p: Notice the bottom control bar, it's not at the bottom on the screen and the video has borders on the sides and the text is tiny: enter image description here

1080p: This is the only one that works as expected, i.e. controls right at the bottom, and good font size and no borders on the sides: enter image description here

1440p: Notice the bottom control bar, it's not at the bottom on the screen and the video has borders on the sides: enter image description here

How do I correct this problem so I can play all different video resolutions at full screen.

The flash version I have installed in Chromium is Adobe Flash Player - Version: 11.2 r202 - Shockwave Flash 11.2 r202

share|improve this question
    
Which browser are you using? Have you checked it in all the browsers? –  Saurav Kumar Oct 24 '13 at 19:08
    
Those screenshots are from Chromium. I have just tried it in Firefox and I get the same results. –  oshirowanen Oct 24 '13 at 19:20
    
Does this or similar issues occur on other video sites? Are you using Flash or HTML5 (youtube.com/html5)? If you are using HTML5 try disabling it, if it's disabled try enabling it. If you are using Flash, which plugin do you use (chrome://plugins) and is it the newest version? –  Donarsson Oct 24 '13 at 23:43
    
what graphic card are you using? –  Ohad Cohen Oct 25 '13 at 14:17
    
@oshirowanen: Both chromium and firefox use older version of flash. Hope that would be the issue. You can get latest version of flash only by installing Google-Chrome. Give it a try. –  Saurav Kumar Oct 25 '13 at 19:27

4 Answers 4

up vote 1 down vote accepted
+100

Since you're using a older version of flash I hope that would be the problem.

Any browser other than Google-Chrome doesn't use latest version of flash in Linux. I don't know why Adobe is not releasing latest version of flash for Linux type system, but there is a way to get latest version of flash by using Google-Chrome.

As the main site of Adobe says, the latest version of flash player is 11.9.x for OS like Windows and Mac, but for Linux and Solaris, it is version 11.2.x only :(

You can also check the version of flash you are using by opening adobe's site. Try to open the site using different browsers. You'll get that while using Chrome, it is different.

It would give information as shown below:

image

Although I'm not using latest version of Chrome.

I can understand your problem and know you pain. But it will not cost any thing if you just give it a try. Who knows that would be your solution.

share|improve this answer

Could try the following: Search for "flash" in Ubuntu Software Centre, and install. Check which flash plugins are enabled. Under chrome://plugins/ Check Details Box. Disable .../PepperFlash/libpepflashplayer.so

share|improve this answer
    
The flash version I have installed in Chromium is Adobe Flash Player - Version: 11.2 r202 - Shockwave Flash 11.2 r202 –  oshirowanen Oct 26 '13 at 11:09

Most probable reason might be that all essential packages are not install/updated. Perhaps the best way to install such non-free but essential packages is to install them using ubuntu-restricted-extras. To install this, open a terminal using Ctrl+Alt+t:

sudo apt-get update
sudo apt-get install ubuntu-restricted-extras

Then restart your browser and check again.

share|improve this answer

I had the same problem. For me it was caused by having two screens set to different horizontal positions.

The workaround: go to System settings -> Displays and drag your screens to align horizontally.

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.