Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I start Ubuntu (10.04), the desktop starts and has windows without their window chrome (e.g. they don't have close, minimize, or maximize buttons). When I click on the "show desktop" icon, the following message pops up:

"Your window manage does not support the show desktop button, or you are not running a window manager."

I can fix this by going to appearance and toggling the visual effects levels to anything different than what they were on.

Based on the behavior and the message, I expect that the window manager is simply not starting correctly when I boot up. What is the best way to make it do so?

Potentially applicable log (from log viewer):

Apr 20 17:46:09 WinterMute acpid: 1 client rule loaded
Apr 20 17:46:09 WinterMute acpid: client connected from 14964[0:0]
Apr 20 17:46:09 WinterMute acpid: 1 client rule loaded
Apr 20 17:46:11 WinterMute gdm-simple-greeter[15041]: Gtk-WARNING: /build/buildd/gtk+2.0-2.20.1/gtk/gtkwidget.c:5636: widget not within a GtkWindow
Apr 20 17:46:18 WinterMute gdm-session-worker[15043]: GLib-GObject-CRITICAL: g_value_get_boolean: assertion `G_VALUE_HOLDS_BOOLEAN (value)' failed
Apr 20 17:46:19 WinterMute gnome-session[15073]: WARNING: Could not parse desktop file /home/tchalvak/.config/autostart/xfconf-migration-4.6.desktop: Key file does not have key 'Name'
Apr 20 17:46:19 WinterMute gnome-session[15073]: WARNING: could not read /home/tchalvak/.config/autostart/xfconf-migration-4.6.desktop
Apr 20 17:46:19 WinterMute gnome-session[15073]: WARNING: Could not launch application '10b602e69f41694b93125011878472406000000044180035.desktop': Unable to start application: Failed to execute child process "/usr/bin/compiz.real" (No such file or directory)
Apr 20 17:46:19 WinterMute gnome-session[15073]: WARNING: Could not launch application 'ubuntuone-client-applet.desktop': Unable to start application: Failed to execute child process "ubuntuone-client-applet" (No such file or directory)
Apr 20 17:46:19 WinterMute gnome-session[15073]: WARNING: Could not launch application '10996e0d149c5579e7125021326532307300000045290042.desktop': Unable to start application: Failed to execute child process "hamster-applet" (No such file or directory)
Apr 20 17:46:20 WinterMute gnome-session[15073]: WARNING: Could not launch application '10996e0d149c5579e712502132692274200000045290043.desktop': Unable to start application: Failed to execute child process "fast-user-switch-applet" (No such file or directory)
Apr 20 17:47:23 WinterMute AptDaemon: INFO: Initializing daemon
share|improve this question
    
Why is it saying compiz if you have it set to metacity? –  RolandiXor Apr 20 '11 at 21:55
    
Not sure. It's certainly set to metacity in that key of gconf-editor. –  Kzqai Apr 20 '11 at 22:03
add comment

2 Answers 2

This is managed by a gconf key:

enter image description here

  • Open the configuration editor (gconf-editor) and ensure that /desktop/gnome/session/required_components/windowmanager is not empty (it should read metacity, compiz, or gnome-wm).

You can also do this from the command line by running:

  • gconftool -s /desktop/gnome/session/required_components/windowmanager -t string metacity

in a terminal or from the recovery console.

  • List item

If metacity doesn't work, you can try compiz or gnome-wm as your option. If they don't work, you can install openbox Install openbox until you find out why neither of these are working.

If none of these work then Gnome is not reading the gconf key for some reason and you have another problem to fix.

Another idea I can think of is to add metacity --replace or compiz --replace to your startup applications.

(NB! this is really a temporary fix because if you do this you will be starting them on any other Desktop Environments you use (like KDE or XFCE).

share|improve this answer
    
It's there and reads: metacity –  Kzqai Apr 20 '11 at 21:36
    
@Tchalvak: try running metacity in a terminal and add the output to your question. Chances are something is going wrong when it attempts to load metacity. If it is not that then chances are you have a more serious problem. –  RolandiXor Apr 20 '11 at 21:37
    
Running metacity & refreshes the window manager and brings the close window icons up on windows. Is there somewhere that I could potentially just put that command, like bashrc or something, to run it well on startup to deal with the problem? –  Kzqai Apr 20 '11 at 21:48
    
I guess I'll check through the logs as well, to see if there's any hint in there. –  Kzqai Apr 20 '11 at 21:49
add comment
up vote 0 down vote accepted

As per the bug here:

https://bugs.launchpad.net/ubuntu/+source/metacity/+bug/351833

And the error in my daemon log about the missing compiz.real:

Creating a symlink from compiz.real to compiz solved the issue:

sudo ln -s /usr/bin/compiz /usr/bin/compiz.real

Everything starts up shiny now!

share|improve this answer
    
Glad you got it solved :D! (I feel a bit useless now but... all in a day's work :P). –  RolandiXor Apr 20 '11 at 22:17
    
Hah, no, your mention of compiz.real made me search for that error, which led me to the bug, which had the solution. –  Kzqai Apr 20 '11 at 22:24
    
:P... –  RolandiXor Apr 20 '11 at 22:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.