Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to upgrade to the latest Ubuntu version 'Saucy Salamander' and someone in my household logged me out at some point during the process. Now I cant' boot up. The computer goes to a GNU GRUB screen offering a list of verions of Linux. I would be grateful for any help. The message I can't get past is : 'Filesystem check of mount failed A maintenance check will now start Control D will terminate this shell and continue booting after re - trying filesystems. Any further errors will be ignored root@matthew ...'

That is it. I can't do anything beyond that point and have to force a shutdown.

My computer is an emachines netbook, small with just USB ports so I was thinking to get a bootable USB as a recovery? Is this a good idea?

Just to update what I am doing. The GNU GRUB gives me 4 options, the first two are to boot with Ubuntu and the 2nd two are memory tests, so now I'm trying those memory tests.

share|improve this question
Memory Test option will not solve your issue, as it is used to check the errors in your Memory(RAM). Do you get the option Recovery Mode or something like Recovery in the in the Grub Menu? – Saurav Kumar Oct 19 '13 at 10:46
I suggest you to have a look to this well documented question: My computer boots to a black screen, what options do I have to fix it? you may find the answer to your problem. – Boris Oct 19 '13 at 11:37
Managed to boot after configuring dpkg as was suggested here:… – Matt Carter Nov 1 '13 at 5:59
up vote 0 down vote accepted

At the GRUB boot menu you can edit the corresponding entry for your Ubuntu installation and add a kernel parameter fastboot that makes the boot process skip the file checking and possibly avoiding the early stop you are experiencing. Here are the steps:

  1. Select your Ubuntu boot entry and press e to edit it
  2. Select the kernel entry and press e to edit that one too
  3. Add the word fastboot to end of the line and hit Enter
  4. Hit b to boot using the new kernel parameter

Now you should probably gain access to your system again and maybe perform a fsck on your file system causing the trouble. If this is not the problem, try performing the system upgrade again, this time gracefully.

Alternatively, try the solution to this question:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.