Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a student and using Ubuntu 10.04 and Windows 7 as dual boot.

In my college, we have a proxy server, so all I need to use the internet is set the proxy settings in Preferences -> Network Proxy and I am set to go.

At my home, I have a broadband connection that requires me to enter my username and password and then its all set on Windows. However, I have no idea how to get it right with Ubuntu.

Once I tried doing that by setting the PPPOE settings and then it worked on Ubuntu too, but when I came back to college, the internet stopped working.

All I remember is that I did some stuff with setting some Network Manager stuff to false or something like that, and it continued working with the proxy server too.

Please help me with this, so that I can easily use internet both at home and college too.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Make sure the interface you want to use to connect to the internet isn't configured in /etc/network/interfaces, since that will interfere with NetworkManager handling it.

You should probably also check whether the PPPoE connection you're using, if it's configured in NetworkManager, isn't set to Connect Automatically, since if it is... then it will connect automatically rather than connecting to a non-PPPoE connection profile.

If your PPPoE connection is configured in NetworkManager, you will find it by right-clicking on the NetworkManager icon in gnome-panel, and clicking "Manage Connections...", then going to the DSL tab.

If it doesn't show up there, make sure you don't have special settings for eth0 under /etc/network/interfaces; any line starting with iface eth0 should be removed from there for NetworkManager to take control of that device.

share|improve this answer
    
Thanks. How can I check whether the PPPoE connection I am using is configured in NetworkManager? I remember last time, I had to go through the console to set the PPPoE settings. Can you elaborate your answer, also describing what NetworkManager does and why is this problem arising? –  Jatin Ganhotra Apr 20 '11 at 20:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.