Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got a bug that is reoccuring (no window chrome close/minimize/maximize buttons) that is solved by changing the visual effects level (e.g. from none to normal).

Unfortunately, the desktop is relatively unusable until I change that setting upon each login.

I have the inclining that it might be solved by resetting compiz to it's default settings. How would I go about resetting compiz (or whatever is in charge of those visual effects) to it's defaults?

share|improve this question

2 Answers 2

up vote 7 down vote accepted

GUI Option

For 11.04 and below:

  • Log into a recovery console,
  • gnome-settings-daemon && gnome-appearance-properties && metacity and press enter.
  • When the appearance properties dialogue comes up, change your settings to normal under the effects tab.
  • Close this window, and metacity will run (so you can close the terminal)
  • Close the terminal to log out from recovery mode, and log back into your desktop.

For all versions:

  • Install ccsmInstall ccsm (Compiz Config Settings Manager).
  • Log into the recovery console,
  • Launch ccsm from the terminal, (you may also optionally run metacity).
  • Create a new profile (if you want to use this method) by going to preferences, and clicking on reset to defaults:

enter image description here

  • You can also select the individual plugin causing the problems and reset its values.

Command-Line Option:

Run this command in a terminal (on 11.04 and up):

  • gconftool --recursive-unset /apps/compiz-1

On 10.10 and below:

  • gconftool --recursive-unset /apps/compiz

Credits to James Gifford for the command.

share|improve this answer
    
I can't find compiz user settings in ~/.gconf/, um.. I've used to rm -fr .config/compiz/compizconfig. Well, you may backup this dir once you've done with ccsm. –  Xiè Jìléi May 11 '12 at 0:53

Roland Taylor's GUI answer broke Unity for me in Ubuntu 12.04. Presumably the "defaults" are the wrong "defaults". Instead, this worked (via the terminal or run prompt):

$ unity --reset

share|improve this answer
    
Hmm, I shall try that out. –  Kzqai May 11 '12 at 2:14
    
The method I had mentioned previously wasn't really for Unity specific settings. –  RolandiXor May 11 '12 at 3:57
    
unity --reset actually freezes my whole system... –  Heisenberg Dec 5 '13 at 9:36
    
@Anh I'm no longer using Unity/Compiz, but after the freeze, are the settings reset? If so, then it might be worth running the above when Unity isn't running. (e.g. boot into a command line.) –  Sparhawk Dec 5 '13 at 10:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.