Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I first started using Ubuntu at v13.04 last monday straight onto my new computer, it has only seen Ubuntu. When i bought the desktop i also purchased a D-Link DWA-123 Model USB wifi adapter. It was discovered (although very slow) when using my live-cd to install Ubuntu, however after installation it stopped all together. I then moved my desktop to the router and used Ethernet to run updates and after these updates the wifi adapter was discovered again, however due to playing around with endless "fix"s all over the ask Ubuntu forums i believe i may have mixed up some of the setting around for my drivers. When i start up my desktop my D-link adapter is undiscovered, after openning the terminal and using "sudo modprobe rt2800usb" it is discovered but is very slow and i have attempted to download games in steam and watching the download rate flat line for a few seconds then spike up to maybe 100-200kb/s then flat again. Using my laptop at the same location running win7 i can download at a rate of 400kb/s+ actual download rate through steam, and the internet connection on it is fine.

After having no luck with finding a fix i went out today and purchased a TP-Link TL-WN823N usb wifi adapter. According to the ubuntu or linux compatability page (don't remember which one i was referencing) all models around this one have been reviewed and have been supported for plug and play working at high speeds. I plug it into my desktop and it is undiscovered, i believe from all the forum scrolling i have done that it is a driver issue. As i said this is my first time running Ubuntu and i am very much over this wifi problem (also my sound isn't working, and i have gone into alsamixer and turned auto-mute off, but this is a secondary problem, need wifi working asap). I am not overly familiar with the terminal commands for Ubuntu, so whoever reads this post and has help to offer may you please thoroughly explain what terminal commands etc. i should do to show drivers or make changes as you instruct. Will be checking this constantly so will has fast replies and be so very grateful to anybody who can help me fix this. That is: 1. Get TP-LINK TL-WN823N USB detected and at high speed. 2. If no chance of getting TP-LINK to work, fix D-LINK (certain TP-LINK will be easier) 3. Fix no-sound issue

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

First of all, Ubuntu 13.10 just released, so you may want to install that instead as it has a newer kernel with newer drivers which may have likely solved your issues. However, if you still want to install Ubuntu 13.04, read ahead.

Run ifconfig and check if wlan0 has any dropped packets. If so, lower the MTU in your network settings.

Add modprobe rt2800usb to /etc/rc.local before exit 0. You can edit text files with the command line with sudo nano /etc/rc.local. rc.local executes any commands listed inside of it on boot, so you won't have to manually modprobe it.

You can use lspci to list all of your hardware, and if you pipe lspci to grep you can only show lines that include a certain string, such as lspcie | grep Network, lspci | grep Wireless, lspci | grep VGA, or lspci | grep Audio.

If you want to install the latest kernel 3.12-rc5: cd /tmp; wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-rc5-saucy/linux-headers-3.12.0-031200rc5-generic_3.12.0-031200rc5.201310131952_amd64.deb; wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-rc5-saucy/linux-headers-3.12.0-031200rc5_3.12.0-031200rc5.201310131952_all.deb; wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-rc5-saucy/linux-image-3.12.0-031200rc5-generic_3.12.0-031200rc5.201310131952_amd64.deb; sudo dpkg -i linux*.deb

share|improve this answer
    
I am upgrading to 13.10 now at 30kb/s. –  spiersie Oct 19 '13 at 6:34
    
I ran the upgrade but i didn't have enough space on my root partition (i have a ssd for system and hdd for home), so i went and put in my live-cd and used gparted to increase partition size... and when i rebooted my pc afterwards, with no live cd... the TP-Link adapter lit up for the first time, however no networks available. Put my D-Link one in, enter the sudo modprobe rt2800usb and the D-link works with the networks being available. So i will run the upgrade now, but wanted to let you know that the TP-Link is now being recognised but not networking (i don't know if i have to enable it). –  spiersie Oct 19 '13 at 7:45
    
To enable networking via NetworkManager, run the following: sudo sed -i 's/managed=false/managed=true/g' /etc/NetworkManager/NetworkManager.conf then reboot. –  mmstick Oct 19 '13 at 7:56
    
I will try that asap, just waiting for this upgrade to finish dling, been going for hours, got a loong way to go. –  spiersie Oct 19 '13 at 10:37
    
I ran the command you suggested then upgraded and it now works, thank you so much. –  spiersie Oct 19 '13 at 13:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.