Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Back on 13.04 it didn't occurred. I've upgraded to 13.10, systems apparently working fine, but, when I put it to sleep(using or not using extended monitor) and try to wake up, I see the screen(both), without lock-screen, but completely freeze, Neither tty open, nor the keyboard works.

So, only option remains is to force shut-down. Any clue how to investigate the cause or fix it? Thanks in advance, any info that'll help you could ask!

Ubuntu 13.10 x64 - not a fresh install/upgraded - with Unity
Dell Vostro 3550
AMD Proprietary Drivers - 13.11 / Hybrid with Intel 

--------------------- EDIT ------------------------

The fix has gone, i cant wake from suspend again, and, every time i shutdown/power up, i got like 9 windows from "report problem". this is the error:

enter image description here

share|improve this question

closed as off-topic by Braiam, Lucio, Eric Carvalho, psusi, Avinash Raj May 18 at 7:30

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, Lucio, Eric Carvalho, psusi, Avinash Raj
If this question can be reworded to fit the rules in the help center, please edit the question.

    
I have the same problem. Do you use gnome 3? –  user204603 Oct 19 '13 at 10:18
    
Unity, fix below provided by @Saurav –  krustbr Oct 19 '13 at 18:35

6 Answers 6

Actually there is a bug which you can find in Launchpad.net

Best thing is that there is also a patch through which you can solve this issue.

Follow these steps hope it works for you also:

  • Open terminal and execute these steps:

    sudo cp /etc/default/grub /etc/default/grub_back
    

    taking the backup of original /etc/default/grub file, in case some error occurs we can get back to original state

    sudo gedit /etc/default/grub
    

    opening the file in gedit to make the changes.

    Once file opened replace following line :

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    

    to the line:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force"
    

    Save the file Ctrl+S and close Ctrl+Q

Note: The next line to the line mentioned above should be GRUB_CMDLINE_LINUX="" not GRUB_CMDLINE_LINUX="acpi_osi=Linux"

  • Now execute following command to update the grub

    sudo update-grub
    
  • Re-start your system once.

Note: If you have trouble in brightness also and above method doesn't fix it then you can test by adding these lines in place I mentioned above.

2. GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

or

3. GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor pcie_aspm=force"

or

4. GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

or

5. GRUB_CMDLINE_LINUX_DEFAULT="pcie_aspm=force"

or

6. GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nomsi"

Note: You have to do a sudo update-grub and a system restart every time you change the grub file

Different system would need different options, if any of the option works, I request to mention that in the comment.

Reply if something goes wrong..

share|improve this answer
    
I was having this issue back on 13.04, and used it on grub to fix: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor" GRUB_CMDLINE_LINUX="acpi_osi=Linux" (its my actual grub) i'll try this new config –  krustbr Oct 19 '13 at 16:48
    
If any of the settings helped you then I would like you to mention the line which actually fixes your issue.. It would help others also to get through their issue.. –  Saurav Kumar Oct 19 '13 at 16:50
    
Hello saurav, ive used the: " GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force"" But i got no good. With the old grub config, the system freezes with a black screen, i can move the pointer once, so it freezes. Here the video: youtu.be/0kKfb2xeen4 –  krustbr Oct 19 '13 at 17:00
    
Did you check after a system restart. If you can access your system then try to check other options also. And please note that it is necessary to do a system restart. I'm adding some more option please check it one by one. –  Saurav Kumar Oct 19 '13 at 17:47
    
@krustbr: And one thing I just noticed that in my grub file there is not value for GRUB_CMDLINE_LINUX. Did you ever change your grub before and added the value like: GRUB_CMDLINE_LINUX="acpi_osi=Linux". Once try to remove this and do the method what I preferred you first.. I know I would be difficult and time consuming but sorry! Try all options with line option : GRUB_CMDLINE_LINUX="" which is on the 2nd line.. –  Saurav Kumar Oct 19 '13 at 17:54

In my system (Samsung Chronos 7 with hybrid graphics, using fglrx drivers because the open source ones makes the system not bootable (1)), the suspend/resume if successful only if made from a virtual console. So I had to add the file(2):

-rwxr-xr-x 1 root root 152 Dec  7 12:09 /etc/pm/sleep.d/01_switchvt

with the contents:

#!/bin/sh

# Switch to a VC before suspending and back after resume

case "$1" in
        resume|thaw)
            chvt 7
        ;;
        suspend|hibernate)
            chvt 1
        ;;
esac

You could need this instead or in addition to Saurav solutions.


Footnotes:

(1) Update: I now can use open-source drivers. It was an overheating problem.

(2) Step-by-step:

  1. edit/create the file

    gksudo gedit /etc/pm/sleep.d/01_switchvt

  2. copy and paste the content above

  3. save and exit
  4. make it executable:

    chmod 755 /etc/pm/sleep.d/01_switchvt

share|improve this answer

When I installed fglrx on Saucy for my Radeon 6870, I experienced the same problem. I tried Saurav Kumar's method, but none of those boot parameters worked. From here, though, I found and tried adding "nomodeset" as a parameter, and I was able to resume from suspend normally.

share|improve this answer
    
Thanks for your information, I'll add this also to one of the options in my answer. Actually different version of system acts differently and it is not sure which patch will work for particular system. :) –  Saurav Kumar Oct 24 '13 at 3:24

Replacement of the Grub line with GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset" was not enough for me.

At restart my screen resolution was downgraded and wakeup from suspend was still not working.

I had to change the video card driver from the "nouveau" (open source) to the NVidia (proprietary).

Altogether, it now works.

share|improve this answer

I had all kind of problems with that same laptop model and the 13.11 Beta proprietary driver, which by the way, states it is for Xorg/Xserver 6.9 and above (up to 1.13) and Saucy has Xorg version 1.14.

Anyway, almos all of my problems went away after running:

$sudo aticonfig --initial

Hope that helps...

share|improve this answer

Mac, thanks for that script, it came closer to solving the problem than anything else in this thread. None of that had any effect at all, except nomodeset, which had the bad effect of leaving me in low graphics mode, which on my HP Envy 15 means it will hang there :p

After installing the script, I was able to close the lid, open it, and see a password prompt instead of a black screen. There's only one problem, though: at least on my machine, the script prevents it from suspending at all. The HP logo on the lid remains lit and the system fans do not stop. The screen powers off, but that's it.

I have minimal scripting skills and don't know the kernel and X well enough to patch the script to fix this problem myself, can you help?

Thanks!!

share|improve this answer

protected by Community Oct 29 '13 at 10:02

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.