Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I recently did a fresh installation of Ubuntu 13.10; but there is something bothering me, which I don't quite understand.

When I first tried to toggle the keyboard language(I usually switch between Persian and English) using the good old "Alt+Shift" shortcut it didn't work. Then, I went and checked the Keyboard shortcut settings and found out that it had been set to "Super+Space"(which BTW didn't work either). So I tried to change it back to "Alt+Shift" but it just doesn't work; when I press "Alt+Shift" to set it up as the toggle-language shortcut, the box automatically resets itself to its previous value(without any errors whatsoever). As far as I've checked I couldn't find any thing obvious corresponding to the shortcut "Alt+Shift" either.

I've currently set up the shortcut as "Ctrl+Space"; so I can toggle the language. My question is why I cannot set it up to just "Alt+Shift"?

share|improve this question

marked as duplicate by Radu Rădeanu, Seth, Kevin Bowen, Lucio, Warren Hill Nov 2 '13 at 9:04

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
@GunnarHjalmarsson Which is a duplicate itself as well!! –  Ali Oct 20 '13 at 23:03

3 Answers 3

I had the same problem after upgrading to Saucy.

Here's how I fixed it. First you need dconf-editor, so just install it by typing (in a terminal):

sudo apt-get install dconf-editor

After installed run it by typing

dconf-editor

In the new window browse to Desktop -> ibus -> General -> Hotkey
then change the next-engine & next-engine-in-menu values to something like this:

['Shift_L+Alt']  

Close the window and go to the text entry settings.
They should now allow you to use Alt+Shift

if the above doesn't help, try this :

sudo add-apt-repository ppa:attente/1218322
sudo apt-get update
sudo apt-get upgrade

then restart.

share|improve this answer
    
Hi Taleb, I just tried what you said, but it didn't work for me. –  Ali Oct 27 '13 at 19:15
    
try the second fix that i just added –  ArK Oct 27 '13 at 21:00
    
Second method worked! –  Rytis Alekna Nov 4 '13 at 7:50
    
GOOD POINT: The first method didn't work when I pasted ['Shift_L+Alt'] then I left it as is and went to Text Entry Settings here I changed the keyboard shortcut to ALT+SHIFT for both. At first it gave me an error message but for the second time it worked. I didn't add attente. –  phpGeek Jan 7 at 16:51
1  
I love you <3 .. first method worked like a charm! –  Saud AlFadhli Nov 24 at 22:49

To set Shift+Alt combination as your language switcher use the following:

Tweak Tool -> Typing -> Key(s) to change layout

This will change the layout using whatsoever key combination you chose from the menu. But it will not change the Layout indicator in Ubuntu 13.10 (Unity)

Install Tweak Tool from Ubuntu Software Center

share|improve this answer
    
It didn't work for me. –  Ali Oct 20 '13 at 23:08
    
Try typing while you are switching layouts, do not look at the layout indicator, it will not affect the indicator. –  MIH1406 Oct 21 '13 at 0:06
    
It doesn't work for me either. Tweak Tool shows my choice (CapsLock), but switching doesn't work. –  brownian Oct 22 '13 at 6:54

I had exactly the same problem

After I installed

sudo add-apt-repository ppa:attente/1218322

That didn't work. So I openned

dconf-editor Desktop -> ibus -> General -> Hotkey

There combination 'Shift_L+Alt' was already set for next-engine & next-engine-in-menu, but has nothing changed. So I changed

> [Shift_L+Alt'] to [] >

After reboot I was able to set 'Shift+Alt' key in 'Text Entry Settings'

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.