Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On my HP Envy, which has both an Intel on-chip graphics card and an Nvidia Geforce:

*-display UNCLAIMED     
   description: 3D controller
   product: GK208M [GeForce GT 740M]
   vendor: NVIDIA Corporation
   physical id: 0
   bus info: pci@0000:01:00.0
   version: a1
   width: 64 bits
   clock: 33MHz
   capabilities: cap_list
   configuration: latency=0
   resources: memory:d2000000-d2ffffff memory:a0000000-afffffff  memory:b0000000-b1ffffff ioport:5000(size=128) memory:b2000000-b207ffff
*-display
   description: VGA compatible controller
   product: 4th Gen Core Processor Integrated Graphics Controller
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 06
   width: 64 bits
   clock: 33MHz
   capabilities: vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:46 memory:d3000000-d33fffff memory:c0000000-cfffffff ioport:6000(size=64)

I have trouble with all newer kernels. I basically had to install 12.04 LTS and use their 3.5 kernel family to get the system to boot. The 3.8 from 12.10 or the newest 3.11 from Ubuntu 13.10 leave me with a black screen upon boot. On one occasion I did hear the "log in" sound, but the screen did not display anything. I have purged all nvidia drivers so I guess it should just use the intel drivers, but apparently this is all messed up with newer kernel versions.

This is different from the other "nvidia boots into blank screen" bug in that I don't rely solely on an nvidia card. Surely the intel on-chip card should be supported and leave me with something different from a blank screen?

Again, it only works with kernel versions 3.5.0-41-generic, not with the 3.11.0-12 one that ships with Ubuntu 13.10.

When I go into the grub menu and change the boot options from 'quiet splash' to 'nomodeset' I am able to boot the system, but then I don't get any graphics and trying 'sudo service lightdm start' doesn't succeed (I get 100% CPU for apport, but this doesn't do anything either, so I kill it).

Help, I'm all out of ideas.

EDIT: Let me add that I'm using the EFI boot system and have a dual-boot installation with Windows 8.

share|improve this question

3 Answers 3

Turns out that everything was more or less fine, just that the screen brightness upon boot was set to 0. I have no idea why this change in behaviour coincides with going to a newer kernel, but at least now everything works when I just increase the screen brightness.

Next step: Figure out how to make it boot with full brightness.

share|improve this answer

I have exactly the same problem on the same PC and also figure it out that increasing screen brightness showed up login screen.

Did you manage to change screen brigthness != 0 at start up?

Concerning the graphics card, do you manage to change between intel/nvidia?

Thank you

share|improve this answer
    
I found that it is pretty random. Sometimes it starts up with normal brightness, sometimes it doesn't. There's a tip here askubuntu.com/questions/79983/… but it doesn't seem to work reliably –  Lagerbaer Nov 2 '13 at 23:13

Uninstall all previous drivers you have and do the following:

sudo apt-get install nvidia-319 nvidia-settings-319 nvidia-prime

Then go to nvidia drivers setting page and set intel gpu for daily use.

PS: The prime package is for Hybrid systems, this will work perfect for you, if you find any updated driver please tell me and I will change the 319 for the newest version, thank you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.