Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed gedit-developer-plugins on a fresh Ubuntu 13.10 Saucy Salamander

I've lauched gedit (from the terminal) but when I turn a GDP plugin on (in this case GDP Find) I get the following error:

(gedit:3640): libpeas-WARNING **: Could not find loader 'python' for plugin 'gdpfind'

The same error only shows while turning on GDP plugins, the others work well.

Any solution to make this plugins work again?

share|improve this question

2 Answers 2

I'm afraid things may depend on the developer responsible for the plugin. But, you could first try the solution presented here: Problem With Gedit Plugins and Python3 on 13.04.

I updated to Lubuntu 13.10 and installed the gedit version available in the software center (v 3.8.3). Then I tried to install doublesave and markdown-preview both of which worked for me in Lubuntu 13.04. I ran into the same problem as you and changing Loader= as suggested in the first link didn't help me.

I did an internet search and concluded that the issue maybe something that the individual plugin developer has to modify unless the Loader= fix works for you.

share|improve this answer
1  
I've tried the Loader= solution without any luck Sadly, I think it's a plugin problem –  Francisco Tomé Costa Oct 19 '13 at 10:35
1  
Well, I've started using geany. It has the equivalent plugins I need. Why don't you take a look? apt-cache --names-only geany will give you a list of the plugins easily available. –  user25656 Oct 19 '13 at 10:48
up vote 1 down vote accepted

It seams that the old plugin (0.5.15) use the python provided by old gedit (3.6)

it's possible to get the stable plugins (1.1.0) that with with gedit (3.8.3) in saucy at https://launchpad.net/~sinzui/+archive/ppa

Just run:

sudo add-apt-repository ppa:sinzui/ppa
sudo apt-get update 
sudo apt-get install gedit-developer-plugins

And then you can turn the GDP plugins on.

EDIT for UBUNTU 14.04

To enable GDP Format plugin you must install python-pocket-lint, just run:

sudo apt-get install python-pocket-lint

If you are in a hurry, just do everything in one command:

sudo add-apt-repository -y ppa:sinzui/ppa && sudo apt-get update && sudo apt-get -y install gedit-developer-plugins python-pocket-lint
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.