Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem with my sound card. I don't have volume up or down option anywhere. In the setting -> Sound I don't have any card detected. But when I run the command sudo aplay -l, I get the following output

**** List of PLAYBACK Hardware Devices ****
Failed to create secure directory (/home/ganessh/.config/pulse): Permission denied
card 0: MID [HDA Intel MID], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

And the command lspci -v | grep -A7 -i "audio" outputs

00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
    Subsystem: Dell Device 02a2
Flags: bus master, fast devsel, latency 0, IRQ 48
Memory at f0f20000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel

00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06) (prog-if 00 [Normal decode])
--
02:00.1 Audio device: NVIDIA Corporation GF106 High Definition Audio Controller (rev a1)
Subsystem: Dell Device 02a2
Flags: bus master, fast devsel, latency 0, IRQ 17
Memory at d3efc000 (32-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel

 07:00.0 Network controller: Intel Corporation Ultimate N WiFi Link 5300

So, I assume that the drivers are properly installed but still I don't get any option in the settings or volume control. The same card used to work well back in 2010 versions(04 and 10)

Edit 1: So the device drivers are properly installed. I was using ntfs file system as my home directory(So I use my files across OS). There is a folder called ~/.config/pulse which was not be set as secured folder by Ubuntu. So the process to access it was failing and my sound card was not available to me for use. Changed my home directory to ext4 and everythin works perfectly.

share|improve this question

1 Answer 1

It was the stupidest mistake ever I have done. I setup a NTFS partition as my home directory. It was wrong. When I mounted NTFS partition, I didn't have permission for the files on it, so the config files failed to load and it led to the problem.

Don't mount NTFS partition on home folder

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.