Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I got my new ASUS netbook, I could click on the Firefox icon on the left margin and I got the Mozilla Firefox startpage and could type in any website I wanted. Now I get the Ubuntu startpage instead. I really want the Firefox startpage. How do I get it?

I downloaded the Safari browser but don't know how to install it, so its icon does not appear.

share|improve this question
add comment

4 Answers

In Firefox, go to Edit -> Preferences -> General -> Home Page. Put whatever URL you want in there.

EDIT: You can enter "about:home" (without quotes) in for the Home Page to set it to the Mozilla Firefox Start Page

share|improve this answer
add comment

Go into the Preferences (Edit -> Preferences) and on the "General"-Tab do the following:

  • Select

    When Firefox is starting: Show Startpage

  • and as Startpage you just use:

    about:home

    and save those settings by clicking "close". Try a browser restart and it should work.

You can also use "about:home" as an url to visit this page at any time.

Please note that Safari is not available for Linux. It's available for Mac OSX and Windows only.

share|improve this answer
add comment

To restore the default home page, Mozilla support recommends the following procedure:

  1. Go to the menu Edit > Preferences.
  2. Select the General tab.
  3. Click on "Restore to Default". Click on "Restore to Default"
  4. Click on "Close".

Ubuntu comes with Firefox installed together with the Ubufox extension, which is the one responsible for changing the default start page from Firefox's to Ubuntu Start Page. If that's the version of Firefox you have, the above procedure will set the same Ubuntu Start Page you don't want (in other words, this procedure is valid for a vanilla install of Firefox).

To set manually the standard Firefox Start Page, just type about:home in the field "Home Page", as suggested in other answers.

Image credit: Mozilla (see link above)

share|improve this answer
1  
This does not work on ubuntu, because it will lead to the ubuntu-flavored start page, not to about:home. At least on my 13.10 installation. I think there is a ubuntu-firefox plugin causing this, so someone could deactivate this plugin or just write the wanted startpage into the field. –  chocobai Oct 19 '13 at 13:28
    
@chocobai I'm sorry I missed this detail. I have updated the answer accordingly. Thank you very much. –  carnendil Oct 21 '13 at 17:12
add comment

Check here http://support.mozilla.org/en-US/kb/How%20to%20set%20the%20home%20page .................................................................................

share|improve this answer
1  
Welcome to AskUbuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  carnendil Oct 18 '13 at 19:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.