Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have quite a specific problem with Ubuntu installation (10.10, 64bit).

I have a hard drive, say /dev/sda where 32 bit ubuntu 10.10 had been installed on sda1. I removed this installation with mkfs and now this partition is clean. I burned a start-up Ubuntu disc and I am trying to install it.

For some strange reasons ubuntu installer mounts this drive as /cdrom and I can't go on with the instalation because 'It cannot be unmounted" and "partition table cannot be altered"

I don't want to repartition the HDD neither to format anything. The only changes I introduced to the partition table within the installer was to set up mounting points.

So how to install Ubuntu in this case? I've tried a lot of different things, e.g. it doesn't help to move the HDD to another controller. So even if /dev/sda is a clean new HDD and /dev/sdb is the HDD of interest, the stupid installer still mounts it (now /dev/sdb)

So I did another experiment: I put a third HDD into the machine. Now it looks as follows:

  • /dev/sda1 - 1TB (irrelevant HDD with ext3 partition)
  • /dev/sdb1 - 1TB with another Ubuntu 10.10 32 bit installation
  • /dev/sdc1 - 1TB THE HARD DRIVE, where Ubuntu 10.10 32 bit used to be installed

Unfortunately even now the installer says "your installation medium is /dev/sdc1" WHY? Why there but neither on /dev/sda1 nor on /dev/sdb2???

Although now I have 3 HDDs, I can't play too much with them, because:

  • /dev/sdb1 holds my backup of /dev/sda1
  • /dev/sdc1 is borrowed from another machine and I don't want to have yet another problem with ubuntu installation (when I would mess up /dev/sdc1)

I also need to keep partition table on the target drive because there are other partitions there with users' data

share|improve this question

OK, I still don't know what is the reason for the strange behavior of Ubuntu installer, but I solved the problem by installing Gentoo on the partition.

After that the installation of ubuntu (on gentoo partition) went as it should (exactly as it is described in a manual)

share|improve this answer
Self answers are good. – James Apr 22 '11 at 0:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.