Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got a problem about the detection of my WiFi card on other Linux kernel versions. When I run ifconfig, the card won't be listed in the network interfaces. The command line sudo ifup ra0 shows the following:

ifup: failed to open statefile /run/network/ifstate: Permission denied

I currently use the "3.8.0-25-generic x86_64" kernel version in order for me to be able to connect to WiFi. All other kernel versions simply won't allow it.

I want to solve this issue before upgrading on 13.10 (I don't think upgrading will solve it at all, or will it?).

Here are all the informations needed:

Command lines results under working kernel: http://pastebin.com/mfFZZ6an

Command lines results under other kernels: http://pastebin.com/aVBSMZx3

Thank you very much for your help.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It appears that you compiled the driver rt5390sta from source code. It is compiled only for the kernel version that was running when you compiled. When a later kernel version is installed, typically by Update Manager, you must re-compile after rebooting into the later kernel.

cd Desktop/rt5390sta_files  <--or wherever you downloaded and extracted the driver
make clean
make
sudo make install
sudo modprobe rt5390sta

I expect that upgrading to 13.10 will probably solve your issue.

share|improve this answer
    
It worked. Thank you so much! –  user204279 Oct 18 '13 at 19:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.