Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This morning, I upgraded from Kubuntu 13.04 to Kubuntu 13.10, and I lost my internet connection after the upgrade. The internet connection is ethernet to a DSL Modem. I know there is nothing wrong with the internet as everything else is working.

The computer is a desktop PC and only connects to the internet via a DSL Modem using an ethernet cable.

The error message I am getting is IP Configuration was unavailable.

Can someone explain how to fix this?

share|improve this question
1  
Can you edit the output of lspci into your question please? –  Seth Oct 19 '13 at 0:54
add comment

3 Answers 3

Can you please try booting from a Live CD (either Ubuntu or Kubuntu) to see if you experience the same problem? If affirmative, we might be affected by the same bug and Losing wired connection after upgrading to 13.10, which I asked, might be a duplicate. I also wanted to let you know that I filed bug #1241897.

Please, follow Seth's instructions as well and paste your lspci output. Do you have a Marvell Ethernet Controller?

share|improve this answer
    
A workaround is to use an older kernel from raring. 3.8 branch should be fine. –  Montblanc Oct 20 '13 at 20:55
    
Tried an older kernel, but this did not work. Yes I do have a Marvell Ethernet Controller. Unfortunately, I have only just seen your post and with frustration, I moved to Mint 15, and everything is now working. –  Andy5 Oct 21 '13 at 15:48
add comment

I was facing the same problem, but a system update solved it. Can you get to an ethernet cable and try to update your system? If not, can you use your phone tethering to try and avoid using wireless?

The steps I used were:

  • Switch off wireless on the laptop
  • Attach my phone in tethering mode (became usb0 network interface)
    • If you use ethernet, it will be eth0
  • Open a terminal, type "dhclient eth0" (or usb0)
  • After that, type "sudo apt-get update"
  • Upgrade the system using "sudo apt-get -y dist-upgrade"

Note that NetworkManager will try to take over the connection every so often, and de-configure it. I couldn't find how to disable the service. After the system update, rebooting the machine fixed the network issues. Hope it works for you too!

share|improve this answer
    
It is a desktop PC and so has no wireless connection. My desktop only connects to the internet via an ethernet connection via a DSL modem. So, I do not know how I can make my desktop connect to the internet via any other method. –  Andy5 Oct 18 '13 at 18:40
    
@Andy5: That's even better, you can completely ignore the first step. Everything else should still be the same (i.e. using dhclient to get internet, and then immediately upgrading the system). –  Rohan Dhruva Oct 18 '13 at 18:43
    
Sorry, but how to do connect a desktop pc to the internet with a phone? Do you mean plug a mobile phone with a usb connection? –  Andy5 Oct 18 '13 at 18:48
    
If you already use ethernet, no need to connect the phone. I suggested using the phone in case you don't have ethernet. Follow everything from step 3 onwards, and ignore the part about usb0. Basically, you need to try and get your system up to date. –  Rohan Dhruva Oct 19 '13 at 3:04
add comment

what if the output of sudo apt-get -y dist-upgrade

is

E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable) E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

Cheers

share|improve this answer
    
You most likely have a graphical package manager open. Linux will only allow a single process to install/remove/change packages at a time. simply close any other open package manager an try again –  Emanuel Ey Feb 27 at 11:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.