Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I went through loads of posts looking for an answer to my WiFi problems but can't seem to fix it.

I had Ubuntu 12.04 installed and WiFi worked fine with no issues whatsoever but then I upgraded to 13.10 it has stopped working.

It shows the available networks but I can't connect to any of them it just does that animation thing then stops working.

Update

Heres the link to pastebin: http://pastebin.com/GyMMEYhv

And heres what wifi card i have and driver

lspci:

01:00.2 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0a)
        Subsystem: Hewlett-Packard Company Device [103c:18de]
        Kernel driver in use: r8169
02:00.0 Network controller [0280]: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe [1814:3290]
        Subsystem: Hewlett-Packard Company Device [103c:18ec]
        Kernel driver in use: rt2800pci
share|improve this question
    
What kind of Wifi card do you have? Which driver are you using? Please edit the question with these information. –  user68186 Oct 18 '13 at 13:51
    
It is safe to run it was written by me and some good friends it will help diagnose your wireless issue. Paste this command in a terminal wget -N -t 5 -T 10 http://dl.dropbox.com/u/57264241/wireless_script && chmod +x wireless_script && ./wireless_script It will download a script and create a file named (wireless-info.txt, or wireless-info.txt.tar.gz) in your home folder paste the contents of the file here pastebin.com then paste the link back here. –  Wild Man Oct 18 '13 at 16:13
    
user68186 and wild man i updated my post thanks for any help :) –  Gary Mclean Oct 18 '13 at 19:51

1 Answer 1

I had same issue and it became to work after this: go to Settings -> Software & Updates -> Additional Drivers and turn off Wireless LAN Controller (select Do Not Use Device -> Apply) and then turn on it again. During this process I was connected to internet via ethernet wire

share|improve this answer
    
i tried that, it only shows additional drivers for the graphics cards - think im going to have to install W8 then use ubuntu in a virtual box or something :( –  Gary Mclean Oct 22 '13 at 20:22

protected by Community Oct 22 '13 at 9:33

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.