Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Previously in (K)ubuntu 13.04, I could play Team Fortress 2 (TF2) on my nvidia-optimus laptop using bumblebee.

I would do this by setting its launch options in Steam to


Since the upgrade to (K)ubuntu 13.10, TF2 will not start from steam. Using the script from the above answer also fails on the terminal with

./hl2_linux: error while loading shared libraries: cannot open shared object file: No such file or directory

How can I get TF2 to run?

share|improve this question
up vote 0 down vote accepted

It seems that Ubuntu 13.10 is missing a file that bumblebee expects to find. To recreate it,

$ cd /usr/lib/i386-linux-gnu/
$ sudo ln -s

This is actually documented elsewhere on the internet, but you have to do this even if you are on a 64-bit system, as TF2 only runs as 32-bit.

share|improve this answer
As an addendum, I now set TF2's launch options to primusrun %command%. (FWIW I've moved to Arch, but this should work in Ubuntu, too.) – Sparhawk Sep 30 '14 at 0:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.