Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was trying to install Hadoop (single node pseudo cluster mode) on Ubuntu 12.04 (3.2). I tried various methods but couldn't get it to work. One of the ways I tried was to install CDH3 and CHD4 packages provided by Cloudera. While trying out CDH, I first installed CDH3, then uninstalled it, then installed CDH4 and then uninstalled it as well - as it was not working either.

Right after this, the system started throwing errors whenever I try to install or update any other software.

The error log generated while installing PDF Mod:

installArchives() failed: perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_IN.ISO8859-1"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_IN.ISO8859-1"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_IN.ISO8859-1"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_IN.ISO8859-1"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Selecting previously unselected package cli-common.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 268418 files and directories currently installed.)
Unpacking cli-common (from .../cli-common_0.8.2_all.deb) ...
Selecting previously unselected package libmono-system-xml4.0-cil.
Unpacking libmono-system-xml4.0-cil (from .../libmono-system-xml4.0-cil_2.10.8.1-        1ubuntu2.2_all.deb) ...
Selecting previously unselected package libmono-system-security4.0-cil.
Unpacking libmono-system-security4.0-cil (from .../libmono-system-security4.0-    cil_2.10.8.1-1ubuntu2.2_all.deb) ...
Selecting previously unselected package libmono-system-configuration4.0-cil.
Unpacking libmono-system-configuration4.0-cil (from .../libmono-system-    configuration4.0-cil_2.10.8.1-1ubuntu2.2_all.deb) ...
Selecting previously unselected package libmono-system4.0-cil.
Unpacking libmono-system4.0-cil (from .../libmono-system4.0-cil_2.10.8.1-    1ubuntu2.2_all.deb) ...
Selecting previously unselected package libmono-security4.0-cil.
Unpacking libmono-security4.0-cil (from .../libmono-security4.0-cil_2.10.8.1-    1ubuntu2.2_all.deb) ...
Selecting previously unselected package mono-4.0-gac.
Unpacking mono-4.0-gac (from .../mono-4.0-gac_2.10.8.1-1ubuntu2.2_all.deb) ...
Selecting previously unselected package mono-gac.
Unpacking mono-gac (from .../mono-gac_2.10.8.1-1ubuntu2.2_all.deb) ...
Selecting previously unselected package mono-runtime.
Unpacking mono-runtime (from .../mono-runtime_2.10.8.1-1ubuntu2.2_amd64.deb) ...
Selecting previously unselected package libmono-corlib4.0-cil.
Unpacking libmono-corlib4.0-cil (from .../libmono-corlib4.0-cil_2.10.8.1-    1ubuntu2.2_all.deb) ...
Selecting previously unselected package libglib2.0-cil.
Unpacking libglib2.0-cil (from .../libglib2.0-cil_2.12.10-2ubuntu4_amd64.deb) ...
Selecting previously unselected package libgconf2.0-cil.
Unpacking libgconf2.0-cil (from .../libgconf2.0-cil_2.24.2-1_all.deb) ...
Selecting previously unselected package libgdiplus.
Unpacking libgdiplus (from .../libgdiplus_2.10-3_amd64.deb) ...
Selecting previously unselected package libmono-cairo4.0-cil.
Unpacking libmono-cairo4.0-cil (from .../libmono-cairo4.0-cil_2.10.8.1-    1ubuntu2.2_all.deb) ...
Selecting previously unselected package libmono-system-drawing4.0-cil.
Unpacking libmono-system-drawing4.0-cil (from .../libmono-system-drawing4.0-    cil_2.10.8.1-1ubuntu2.2_all.deb) ...
Selecting previously unselected package libgtk2.0-cil.
Unpacking libgtk2.0-cil (from .../libgtk2.0-cil_2.12.10-2ubuntu4_amd64.deb) ...
Selecting previously unselected package libmono-corlib2.0-cil.
Unpacking libmono-corlib2.0-cil (from .../libmono-corlib2.0-cil_2.10.8.1-    1ubuntu2.2_all.deb) ...
Selecting previously unselected package libmono-i18n-west2.0-cil.
Unpacking libmono-i18n-west2.0-cil (from .../libmono-i18n-west2.0-cil_2.10.8.1-    1ubuntu2.2_all.deb) ...
Selecting previously unselected package libmono-i18n4.0-cil.
Unpacking libmono-i18n4.0-cil (from .../libmono-i18n4.0-cil_2.10.8.1-    1ubuntu2.2_all.deb) ...
Selecting previously unselected package libmono-i18n-west4.0-cil.
Unpacking libmono-i18n-west4.0-cil (from .../libmono-i18n-west4.0-cil_2.10.8.1-    1ubuntu2.2_all.deb) ...
Selecting previously unselected package libmono-posix4.0-cil.
Unpacking libmono-posix4.0-cil (from .../libmono-posix4.0-cil_2.10.8.1-    1ubuntu2.2_all.deb) ...
Selecting previously unselected package libmono-system-core4.0-cil.
Unpacking libmono-system-core4.0-cil (from .../libmono-system-core4.0-cil_2.10.8.1-    1ubuntu2.2_all.deb) ...
Selecting previously unselected package pdfmod.
Unpacking pdfmod (from .../pdfmod_0.9.1-5ubuntu1_all.deb) ...
Processing triggers for man-db ...
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for gnome-menus ...
Processing triggers for hicolor-icon-theme ...
Setting up hadoop (2.0.0+1475-1.cdh4.4.0.p0.23~precise-cdh4.4.0) ...
chown: invalid group: `root:hadoop'
dpkg: error processing hadoop (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of hadoop-hdfs:
 hadoop-hdfs depends on hadoop (= 2.0.0+1475-1.cdh4.4.0.p0.23~precise-cdh4.4.0);     however:
  Package hadoop is not configured yet.
dpkg: error processing hadoop-hdfs (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of hadoop-hdfs-datanode:
 hadoop-hdfs-datanode depends on hadoop-hdfs (= 2.0.0+1475-1.cdh4.4.0.p0.23~precise-    cdh4.4.0); however:
  Package hadoop-hdfs is not configured yet.
dpkg: error processing hadoop-hdfs-datanode (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of hadoop-hdfs-namenode:
 hadoop-hdfs-namenode depends on hadoop-hdfs (= 2.0.0+1475-1.cdh4.4.0.p0.23~precise-cdh4.4.0); however:
  Package hadoop-hdfs is not configured yet.
dpkg: error processing hadoop-hdfs-namenode (--configNo apport report written because     MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
ure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of hadoop-hdfs-secondarynamenode:
 hadoop-hdfs-secondarynamenode depends on hadoop-hdfs (= 2.0.0+1475-    1.cdh4.4.0.p0.23~precise-cdh4.4.0); however:
  Package hadoop-hdfs is not configured yet.
dpkg: error processing hadoop-hdfs-secondarynamenode (--configure):
 dependency problems - leaving unconfigured
Setting up cli-common (0.8.2) ...
Setting up libgdiplus (2.10-3) ...
Setting up libmono-security4.0-cil (2.10.8.1-1ubuntu2.2) ...
Setting up mono-4.0-gac (2.10.8.1-1ubuntu2.2) ...
Setting up mono-gac (2.10.8.1-1ubuntu2.2) ...
* Installing 6 assemblies from libgconf2.0-cil into Mono
* Installing 1 assembly from libglib2.0-cil into Mono
* Installing 5 assemblies from libgtk2.0-cil into Mono
update-alternatives: using /usr/bin/gacutil to provide /usr/bin/cli-gacutil (global-    assembly-cache-tool) in auto mode.
Setting up mono-runtime (2.10.8.1-1ubuntu2.2) ...
update-alternatives: using /usr/bin/mono to provide /usr/bin/cli (cli) in auto mode.
Setting up libmono-corlib4.0-cil (2.10.8.1-1ubuntu2.2) ...
Setting up libmono-cairo4.0-cil (2.10.8.1-1ubuntu2.2) ...
Setting up libmono-corlib2.0-cil (2.10.8.1-1ubuntu2.2) ...
Setting up libmono-i18n-west2.0-cil (2.10.8.1-1ubuntu2.2) ...
Setting up libmono-i18n4.0-cil (2.10.8.1-1ubuntu2.2) ...
Setting up libmono-i18n-west4.0-cil (2.10.8.1-1ubuntu2.2) ...
Setting up libmono-system4.0-cil (2.10.8.1-1ubuntu2.2) ...
Setting up libglib2.0-cil (2.12.10-2ubuntu4) ...
* Installing 1 assembly from libglib2.0-cil into Mono
Setting up libgconf2.0-cil (2.24.2-1) ...
* Installing 6 assemblies from libgconf2.0-cil into Mono
Setting up libmono-system-drawing4.0-cil (2.10.8.1-1ubuntu2.2) ...
Setting up libgtk2.0-cil (2.12.10-2ubuntu4) ...
* Installing 5 assemblies from libgtk2.0-cil into Mono
Setting up libmono-posix4.0-cil (2.10.8.1-1ubuntu2.2) ...
Setting up libmono-system-core4.0-cil (2.10.8.1-1ubuntu2.2) ...
Setting up libmono-system-xml4.0-cil (2.10.8.1-1ubuntu2.2) ...
Setting up libmono-system-security4.0-cil (2.10.8.1-1ubuntu2.2) ...
Setting up pdfmod (0.9.1-5ubuntu1) ...
Setting up libmono-system-configuration4.0-cil (2.10.8.1-1ubuntu2.2) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
 hadoop
 hadoop-hdfs
 hadoop-hdfs-datanode
 hadoop-hdfs-namenode
 hadoop-hdfs-secondarynamenode
Error in function: 
Setting up hadoop (2.0.0+1475-1.cdh4.4.0.p0.23~precise-cdh4.4.0) ...
chown: invalid group: `root:hadoop'
dpkg: error processing hadoop (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of hadoop-hdfs:
 hadoop-hdfs depends on hadoop (= 2.0.0+1475-1.cdh4.4.0.p0.23~precise-cdh4.4.0);     however:
  Package hadoop is not configured yet.
dpkg: error processing hadoop-hdfs (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of hadoop-hdfs-secondarynamenode:
 hadoop-hdfs-secondarynamenode depends on hadoop-hdfs (= 2.0.0+1475-    1.cdh4.4.0.p0.23~precise-cdh4.4.0); however:
  Package hadoop-hdfs is not configured yet.
dpkg: error processing hadoop-hdfs-secondarynamenode (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of hadoop-hdfs-namenode:
 hadoop-hdfs-namenode depends on hadoop-hdfs (= 2.0.0+1475-1.cdh4.4.0.p0.23~precise-    cdh4.4.0); however:
  Package hadoop-hdfs is not configured yet.
dpkg: error processing hadoop-hdfs-namenode (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of hadoop-hdfs-datanode:
 hadoop-hdfs-datanode depends on hadoop-hdfs (= 2.0.0+1475-1.cdh4.4.0.p0.23~precise-    cdh4.4.0); however:
  Package hadoop-hdfs is not configured yet.
dpkg: error processing hadoop-hdfs-datanode (--configure):
 dependency problems - leaving unconfigured

Not sure what to do!

share|improve this question
    
there's a link here askubuntu.com/questions/140246/… –  comrademike Oct 18 '13 at 12:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.