Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have upgraded from Ubuntu 13.04 to 13.10 and it now constantly duplicates my key presses when I am in a browser, HUD or libreoffice. So if I type "ubuntu" it types "uubbuunnttuu". When I press backspace it eliminates two chars at once. The only exception is terminal. It behaves as usual. The problem is very frustrating, I can't get to work with it, please halp me.

share|improve this question
    
Try to mess around with System Settings > Keyboard, you can configure keystroke repeating there. Maybe this already helps. –  mondjunge Oct 18 '13 at 15:08
    
This just started happening to me too. I have no idea what caused it. It's happening if I boot to a console as well, not just in Unity. –  m0j0 Oct 22 '13 at 20:40
add comment

1 Answer

Maybe your keyboard settings got a little out of whack. Try this:

  1. Open your System Settings, either through the Dash of that little cog on the top right corner of your desktop: Desktop
  2. Open the keyboard settings: System Settings
  3. Look at the Repeat Keys settings (under the mouse cursor). Try sliding the "Delay" option towards "Long". You may also like to set "Speed" more closely to "Slow". An extreme alternative would be to disable "Key presses repeat when key is held down", which would require you to press a key once for every sequential repetition you want of it. Keyboard
share|improve this answer
1  
Thank you, Waldir. Actually I tried this before, but forgot to mention it in the question. It doesn't help either. Nor delaying and speeding down key presses repetition, nor disabling it at all. –  Andrei Oct 18 '13 at 11:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.