Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed the vidalia by following these instructions everything went as they mentioned. When I started vidalia it gave me the error:

Vidalia was unable to start Tor. Check your settings to ensure the correct name and location of your Tor executable is specified.

I found that bug here and followed their instructions to fix it and now after that

it says:

Vidalia detected that the Tor software exited unexpectedly. Please check the message log for recent warning or error messages.

Logs of Vidalia

Oct 18 02:15:06.937 [Notice] Tor v0.2.3.25 (git-3fed5eb096d2d187) running on Linux.
Oct 18 02:15:06.938 [Notice] Opening Socks listener on 127.0.0.1:9050
Oct 18 02:15:06.938 [Warning] Could not bind to 127.0.0.1:9050: Address already in use. Is Tor already running? 
Oct 18 02:15:06.938 [Warning] /var/run/tor is not owned by this user (waqas, 1000) but by debian-tor (118). Perhaps you are running Tor as the wrong user? 
Oct 18 02:15:06.938 [Warning] Before Tor can create a control socket in "/var/run/tor/control", the directory "/var/run/tor" needs to exist, and to be accessible only by the user account that is running Tor. (On some Unix systems, anybody who can list a socket can connect to it, so Tor is being careful.) 
Oct 18 02:15:06.938 [Warning] Failed to parse/validate config: Failed to bind one of the listener ports. 
Oct 18 02:15:06.938 [Error] Reading config failed--see warnings above.

Please Help !

share|improve this question
    
possible duplicate askubuntu.com/questions/320875/… –  blade19899 Oct 18 '13 at 9:54
    
i dont have tor browser i have installed only vidalia. How do i change the ownership of the vidalia ? –  Rana Muhammad Waqas Oct 18 '13 at 10:00
    
Vidalia is the graphical controller for tor software, they go hand in hand. And in your question you specifically stated that you use the tor software. Did you only installed Vidalia? –  blade19899 Oct 18 '13 at 10:07
    
if you want to install the tor software please see eurobytes.nl/tutorials/privacy-and-security-security#tor –  blade19899 Oct 18 '13 at 10:09
    
I only installed the vidalia which have the GUI and i didnt downloaded the browser which cames with it –  Rana Muhammad Waqas Oct 18 '13 at 10:14

2 Answers 2

up vote 2 down vote accepted

[Problem Solved]

note: this is for who have only Vidalia
- remove the Vidalia using sudo apt-get autoremove vidalia
- Install it by using sudo apt-get install vidalia
- Start the Vidalia and it will give you the error Vidalia detected that the Tor software exited unexpectedly. Please check the message log for recent warning or error messages.
- Uncheck the option Tor setting
- Select the Advance and choose Use TCP connection(ControlPort) instead of Use unix domainsocket (ControlSocket)
enter image description here
And you are done now run the Vidalia and it will work like a Charm :)

share|improve this answer

Warning Not tested: source

how to quickly fix this problem to browse the Internet anonymously. A temporary solution is to type the following command in the terminal:

sudo killall tor

Restart Vidalia and it should work with tor like a charm. But the real problem is that every time you want to use tor with Vidalia, you will need to input that command in the terminal...

The Problem with tor and Vidalia

Upon installation, tor will automatically start-up when booting Ubuntu. When you open Vidalia, it will first check if there is an existing tor process and try to connect to the control port of tor. All we need to do is reconfigure tor so it allows Vidalia to connect and start using the tor process.

How to solve and fix error message: Vidalia detected that the tor software exited unexpectedly. Please check the message log for recent warning or error messages.

First step: is to open the configuration file of tor. Open a terminal and input this command:

sudo gedit /etc/tor/torrc

After the file opens, scroll down to line 53 to line 60 and you will see something like this:

 ## The port on which Tor will listen for local connections from Tor ## controller applications, as documented in control-spec.txt.
 #ControlPort 9051 ## If you enable the controlport, be sure to enable one of these ## authentication methods, to prevent attackers from
 accessing it. #HashedControlPassword
 16:872860B76453A77D60CA2BB8C1A7042072093276A3D701AD684053EC4C
 #CookieAuthentication 1

Second Step: Remove # from #ControlPort 9051 so line 55 looks like this:

ControlPort 9051

Then enable password authentication by removing # from #HashedControlPassword so line 58 looks like this:

HashedControlPassword

Third Step: Input the following command into the terminal to create a password for tor, but where it says, “mypassword,” replace that with a password of your choosing:

tor --hash-password mypassword

The terminal will respond with a hash that looks like this:

16:816172DEB125A9CA603A6A8A5C16D0642DA4556E4EC417E6B9AAC9AF0D

Copy this entire hash string, and then replace the defauld value on line 58.

This is how our torrec file looked like when we finished configuring it:

## The port on which Tor will listen for local connections from Tor ## controller applications, as documented in control-spec.txt. ControlPort 9051 ## If you enable the controlport, be sure to enable one of these ## authentication methods, to prevent attackers from accessing it. #HashedControlPassword 16:816172DEB125A9CA603A6A8A5C16D0642DA4556E4EC417E6B9AAC9AF0D #CookieAuthentication 1

Fourth Step: Save the torrc file: ctrl + s and close it. Then restart tor by inputing this to a terminal:

sudo /etc/init.d/tor restart

That's it! Open Vidalia and it should now be able to start and stop tor without a problem. Note: If Vidalia gives you an error with failing to authenticate with tor, just exit vidalia and re-open it.

source

share|improve this answer
    
first you say that remove the # from the HashedControlPassword and at the end when you showed the torrec file there is #HashedControlPassword ? why ? –  Rana Muhammad Waqas Oct 18 '13 at 10:26
    
@RanaMuhammadWaqas as i stated in the question Warning Not tested: if you would like some explanation please see the source link. –  blade19899 Oct 18 '13 at 10:35
    
and no this doesnt work its giving me the same error :/ –  Rana Muhammad Waqas Oct 18 '13 at 11:24
    
worked great here, the re-appearing '#' is probably just an error, I don't have it and it worked –  flagg19 Oct 1 at 9:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.