Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since a couple of days now, my unity desktop background smears everything, just like what old Windows versions were famous for:

smeared desktop

Of course, I tried rebooting a couple of times. Also, I switched graphics driver and I tried to change wallpaper and theme, but none of them solved the problem.

What could be causing that problem, and where can I search on for its source?

Infomation update

I'm using Ubuntu 13.04 (not updated to 13.10 yet).

The following commands were all run from cinnamon (on the same Ubuntu installation).

sudo lsb_release -a:

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 13.04
Release:    13.04
Codename:   raring

sudo uname -a:

Linux cedric-MacBookPro 3.8.0-32-generic #47-Ubuntu SMP Tue Oct 1 22:35:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

sudo dpkg -l | grep xserver-xorg-video:

ii  xserver-xorg-video-all                    1:7.7+1ubuntu4                         amd64        X.Org X server -- output driver metapackage
ii  xserver-xorg-video-ati                    1:7.1.0-0ubuntu2                       amd64        X.Org X server -- AMD/ATI display driver wrapper
ii  xserver-xorg-video-cirrus                 1:1.5.2-0ubuntu1                       amd64        X.Org X server -- Cirrus display driver
ii  xserver-xorg-video-fbdev                  1:0.4.3-0ubuntu1                       amd64        X.Org X server -- fbdev display driver
ii  xserver-xorg-video-intel                  2:2.21.6-0ubuntu4.3                    amd64        X.Org X server -- Intel i8xx, i9xx display driver
ii  xserver-xorg-video-mach64                 6.9.3-0ubuntu1                         amd64        X.Org X server -- ATI Mach64 display driver
ii  xservhttps://bugs.launchpad.net/ubuntu/+source/unity/+bug/1244237er-xorg-video-mga                    1:1.6.2-0ubuntu1                       amd64        X.Org X server -- MGA display driver
ii  xserver-xorg-video-modesetting            0.7.0-0ubuntu2                         amd64        X.Org X server -- Generic modesetting driver
ii  xserver-xorg-video-neomagic               1:1.2.7-0ubuntu1                       amd64        X.Org X server -- Neomagic display driver
ii  xserver-xorg-video-nouveau                1:1.0.7-0ubuntu1                       amd64        X.Org X server -- Nouveau display driver
ii  xserver-xorg-video-openchrome             1:0.3.1-0ubuntu1.13.04.1               amd64        X.Org X server -- VIA display driver
ii  xserver-xorg-video-qxl                    0.1.0-0ubuntu3                         amd64        X.Org X server -- QXL display driver
ii  xserver-xorg-video-r128                   6.9.1-0ubuntu1                         amd64        X.Org X server -- ATI r128 display driver
ii  xserver-xorg-video-radeon                 1:7.1.0-0ubuntu2                       amd64        X.Org X server -- AMD/ATI Radeon display driver
ii  xserver-xorg-video-s3                     1:0.6.5-0ubuntu3                       amd64        X.Org X server -- legacy S3 display driver
ii  xserver-xorg-video-savage                 1:2.3.6-0ubuntu1                       amd64        X.Org X server -- Savage display driver
ii  xserver-xorg-video-siliconmotion          1:1.7.7-0ubuntu1                       amd64        X.Org X server -- SiliconMotion display driver
ii  xserver-xorg-video-sis                    1:0.10.7-0ubuntu1                      amd64        X.Org X server -- SiS display driver
ii  xserver-xorg-video-sisusb                 1:0.9.6-0ubuntu1                       amd64        X.Org X server -- SiS USB display driver
ii  xserver-xorg-video-tdfx                   1:1.4.5-0ubuntu1                       amd64        X.Org X server -- tdfx display driver
ii  xserver-xorg-video-trident                1:1.3.6-0ubuntu2                       amd64        X.Org X server -- Trident display driver
ii  xserver-xorg-video-vesa                   1:2.3.2-0ubuntu1                       amd64        X.Org X server -- VESA display driver
ii  xserver-xorg-video-vmware                 1:12.0.2+git.e5ac80d8-0ubuntu1         amd64        X.Org X server -- VMware display driver

sudo lspci | grep VGA:

01:00.0 VGA compatible controller: NVIDIA Corporation GT216M [GeForce GT 330M] (rev a2)

Update 2

This bug might be related: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1244237

share|improve this question
    
Which version of Ubuntu are you using.. It would be good if you provide the output of these commands: sudo lsb_release -a, sudo uname -a, sudo dpkg -l | grep xserver-xorg-video and sudo lspci | grep VGA –  Saurav Kumar Nov 4 '13 at 11:07
    
Okay, edited my question. –  Cedric Reichenbach Nov 4 '13 at 13:47
add comment

2 Answers 2

up vote 2 down vote accepted

By now, I've had the same issue on two different machines. On the first one, it solved itself with a distribution upgrade. On the other one, I followed comment #10's tip in this bug report: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1244237

sudo apt-get purge cinnamon

This command uninstalls Cinnamon (Mint's desktop environment), including Nemo, and deletes all configuration.

Apparently, this problem was related to Cinnamon/Nemo, or the fact that probably two different desktop environments/file managers (Unity/Nautilus and Cinnamon/Nemo) tried to manage destop backgrounds, but I don't know any details.

Update

This article features a version of Nemo for Unity without Cinnamon.

share|improve this answer
    
There is no need to purge cinnamon. You just need to kill nemo and start nautilus instead. $ killall nemo $ nautilus –  madrang Jun 4 at 4:45
add comment

I had the exact same problem as you (Ubuntu 13.04 on a Zenbook Prime) and found your question when searching for an answer. I found it 5 minutes ago (here, on this topic):

Resetting Compiz with the command dconf reset -f /org/compiz/ and then, logging out and in, using gnome-session-quit. That did the trick: the background image reappeared and the refreshing problems disappeared.

share|improve this answer
    
Hmm, I think I already tried this one. But I cannot be sure right now, since I don't have the problematic computer here... –  Cedric Reichenbach Nov 11 '13 at 17:25
1  
A few months later, I had the regrets to see that this solution wasn't definitive. My problem came back many times. The real solution for me was to uninstall Cinnamon (that I installed but finally didn't use) which was apparently making some conflict with Gnome. Do you have other window managers? –  groug Jan 18 at 16:29
    
Roughly the similar problem on a Zenbook prime which typically stops recognizing the second display after a while. I'll then force it to connect with xrandr - after which I'll lose my background (12.04) or it even starts smearing (14.04) –  jan groth May 26 at 11:50
add comment

protected by Community Jan 6 at 20:25

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.