Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I downloaded 13.10 today and installed it with Secure Boot set to off on my Surface Pro in a 10GB Partition. I realized afterwards that for personal reasons I need Secure Boot enabled, so I re-enabled it - Ubuntu won't boot anymore with a "Secure Boot violation".

I basically followed the install here on Ask Ubuntu. Boot-Repair claims to have fixed efi boot capabilities but basically changed nothing about the issue as I still can't boot. I also made sure to have shim, grub and the kernel in a signed version as suggested here: https://bugs.launchpad.net/ubuntu/+source/grub-installer/+bug/1184297.

Am I missing anything? I tried inquiring about this in IRC but was told Secure Boot would simply not work with Ubuntu yet, which to my knowledge is not correct.

share|improve this question
    
Secure Boot is simply not working with ubuntu (yeah, its true!). You need to turn on/off secure boot depending on if you like to start windows 8 or ubuntu (taken from Dan's answer on 265644. –  mondjunge Oct 18 '13 at 12:37
    
Thanks mondjunge. It leaves me a little confused though, as I though Canonical had Microsoft sign stuff to prevent this. –  user204001 Oct 18 '13 at 21:03
    
I also thought so. I just read about it in other forums and blogs. Seems, like the signed kernels are broken. Secure Boot was, after all, really a try to put Linux users down. Now Microsoft is in the position to determine which Linux shall be running and which shall not. Really great, what a Vista, I mean Outlook... –  mondjunge Oct 21 '13 at 9:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.