Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Z77 board with a GeForce GTX 670. My monitor is a Korean 27" IPS with only a single DVI Dual-link connection, and a resolution of 2560x1440. After upgrading to 13.10 today, Unity and the X Window System are non-functional. After booting up, all I see is a screen that flashes between red, green, blue, various blacks, greys, and whites at regular intervals. From here I can switch to command line, and that displays fine, but starting lightdm takes me back to the flashing colors. I had this problem on 13.04, but I was able to fix it by editing xorg.conf with the proper information about my monitor. No such luck for 13.10. I have tried:

  • installing different drivers (i.e. nvidia-current, nvidia-experimental)
  • plugging into both DVI ports on my 670
  • editing xorg.conf myself
  • letting the Nvidia package do the xorg.conf configuration automatically

Admittedly I know very little about X Window system, and all my editing was based on xorg.conf files posted by others that were claimed to work, none of which used the same combination of monitor and video card as mine. I'm out of ideas at this point, input from someone who knows what they're doing would be greatly appreciated.

share|improve this question

2 Answers 2

Article explaining the issue and solution: http://neogregious.blogspot.com/2013/05/korean-ips-monitors-and-nvidia-under.html

Here is a short summary of the solution(credit goes to Greg Fawcett):

Create an xorg conf:

sudo nvidia-xconfig

Now you need to edit the new xorg.conf file:

sudo vi /etc/X11/xorg.conf

Find the section below, and add the - Option "IgnoreEDIDChecksum" "DFP" - line :

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option         "IgnoreEDIDChecksum" "DFP"
EndSection

Save the file, and reboot.

share|improve this answer
    
Thanks very much, I'll try this as soon as I get the chance. –  AdamJames Nov 6 '13 at 2:41

Seems like your graphics drivers are messed up. You'll need to purge all the Nvidia packages you created by experimenting with them:

sudo apt-get purge nvidia*

Then reinstall the Nvidia-current:

sudo apt-get install nvidia-current

Don't forget to reboot!

share|improve this answer
    
I tried that, but no luck. Thanks for the response though. –  AdamJames Oct 18 '13 at 8:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.