Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Upgraded from 13.04 to 13.10 on my Ideapad Yoga yesterday, hoping it might have fixes for a couple of issues I've been having. While it seems to have made the touchscreen more usable, it has made the problem with my trackpad even worse.

In 13.04 and below, the cursor occasionally (maybe once or twice a day) would completely stop working and to get it working again I would run

sudo modprobe -r psmouse
sudo modprobe psmouse

and it would be happy again, now every hour or so, my cursor just goes invisible, you can tell its still there as you can hover over things and they will respond. Again running

sudo modprobe -r psmouse
sudo modprobe psmouse

works but it's getting a little annoying now its so frequent!

Does anyone have any suggestions on things to try?

share|improve this question
    
Maybe [this could help][1]. Worked for me. [1]: askubuntu.com/questions/360423/… –  user2283748 Oct 19 '13 at 4:18
    
Thanks, but I saw that before I posted this and it shows up as just 1 "built-in display" :( –  ConnorRoberts Oct 19 '13 at 13:58
    
possible duplicate of Mouse cursor disappearing at every second boot Ubuntu 13.10 –  Braiam Jan 28 at 15:59

3 Answers 3

up vote 4 down vote accepted

FYI, doug's response here seems to have solved the problem for me. Several hours now with no issue. Using Synergy heavily as well, which was always a sure way to make it vanish.

The gist: gsettings set org.gnome.settings-daemon.plugins.cursor active false

Thanks for the modprobe suggestion, though. That made the issue at least tolerable!

share|improve this answer
    
Thanks, not looked at the other question since - tried that now so will see how it goes :) –  ConnorRoberts Oct 31 '13 at 13:49
    
Worked for a while but it happened again (so much less regularly!) now I could just do with finding out how to do something like the modprobe trick to get it working again :) –  ConnorRoberts Oct 31 '13 at 18:58

Try hitting alt + ctrl + F6, then alt + ctrl + F7.

This will switch two virtual console 6 then back virtual console 7. This brings my mouse pointer back. If it works for you then you can do this automatically by adding a script to:

/etc/pm/sleep.d/

I called mine 'mouse_hack' and in it all I have is: 'chvt 6; chvt 7'.

It should be owned by root, and be executable.

This just automates what you did manually above whenever your computer resumes.

share|improve this answer

This is not a complete answer but may mitigate the problem. This occurs for me when I unlock my computer, among other conditions (VLC, as mentioned, forr example). If you put your modprobe lines into a bash script and place the script in /etc/pm/sleep.d , then it runs automatically on resume, and this for me makes sure I have my pointer each time I wake up my computer.

Bit of a hack for now, but it saves me some trouble at least.

share|improve this answer

protected by Community Jan 28 at 16:27

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.