Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i'm kinda new to linux. last night i tried upgrading from 13.04 to 13.10 but i got the "could not calculate" error. i read this question and found this error in the main log: Dist-upgrade failed: 'E:Unable to correct problems, you have held broken packages.'

and here's a list of my broken packages :

  Broken libwayland-client0:amd64 Conflicts on libwayland0 [ amd64 ] < 1.0.5-0ubuntu1 > ( libs ) (< 1.1.0)
Broken libpam-systemd:amd64 Conflicts on libpam-xdg-support [ amd64 ] < 0.2-0ubuntu2 > ( admin )
Broken cups-filters:amd64 Conflicts on ghostscript-cups [ amd64 ] < 9.07~dfsg2-0ubuntu3.1 > ( text )
Broken libharfbuzz0a:amd64 Breaks on libharfbuzz0 [ amd64 ] < 0.9.13-1 > ( libs )
Broken libunity-scopes-json-def-desktop:amd64 Conflicts on libunity-common [ amd64 ] < 6.90.2daily13.04.05-0ubuntu1 > ( gnome ) (< 7.0.7)
Broken libunity-scopes-json-def-desktop:amd64 Conflicts on libunity-common [ i386 ] < none > ( none ) (< 7.0.7)
Broken libaccount-plugin-generic-oauth:amd64 Conflicts on account-plugin-generic-oauth [ amd64 ] < 0.10bzr13.03.26-0ubuntu1.1 > ( gnome ) (< 0.10bzr13.04.30)
Broken libaccount-plugin-generic-oauth:amd64 Breaks on account-plugin-generic-oauth [ amd64 ] < 0.10bzr13.03.26-0ubuntu1.1 > ( gnome ) (< 0.10bzr13.04.30)
Broken python3-aptdaemon.pkcompat:amd64 Breaks on libpackagekit-glib2-14 [ amd64 ] < 0.7.6-3ubuntu1 > ( libs ) (<= 0.7.6-4)
Broken libsnmp-base:amd64 Breaks on libsnmp15 [ amd64 ] < 5.4.3~dfsg-2.7ubuntu1 > ( libs ) (< 5.7.2~dfsg-5)
Broken libunity-core-6.0-8:amd64 Conflicts on unity-common [ amd64 ] < 7.0.0daily13.06.19~13.04-0ubuntu1 > ( gnome )
Broken python3-uno:amd64 Conflicts on python-uno [ amd64 ] < 1:4.0.4-0ubuntu1 > ( python )
Broken unity-scope-home:amd64 Conflicts on unity-lens-shopping [ amd64 ] < 6.8.0daily13.03.04-0ubuntu1 > ( gnome )
Broken xserver-xorg-video-mach64:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken usb-modeswitch-data:amd64 Breaks on usb-modeswitch [ amd64 ] < 1.2.3+repack0-1ubuntu3 > ( comm ) (< 1.2.6)
Broken unity-gtk2-module:amd64 Conflicts on appmenu-gtk [ amd64 ] < 12.10.3daily13.04.03-0ubuntu1 > ( libs )
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-r128:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken unity-gtk3-module:amd64 Conflicts on appmenu-gtk3 [ amd64 ] < 12.10.3daily13.04.03-0ubuntu1 > ( libs )
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-cirrus:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken libbamf3-1:amd64 Depends on bamfdaemon [ amd64 ] < 0.4.0daily13.06.19~13.04-0ubuntu1 -> 0.5.1+13.10.20131011-0ubuntu1 > ( libs ) (= 0.4.0daily13.06.19~13.04-0ubuntu1)
Broken bzr-gtk:amd64 Depends on bzr [ amd64 ] < 2.6.0~bzr6571-4ubuntu2 -> 2.6.0-3ubuntu1 > ( devel ) (< 2.6.0)
Broken libgphoto2-6-dev:amd64 Conflicts on libgphoto2-2-dev [ amd64 ] < 2.4.14-2 > ( libdevel )
Broken activity-log-manager:amd64 Conflicts on activity-log-manager-common [ amd64 ] < 0.9.4-0ubuntu6.2 > ( utils )
Broken libgjs0d:amd64 Conflicts on libgjs0c [ amd64 ] < 1.34.0-0ubuntu1 > ( libs )
Broken libgtksourceview-3.0-0:amd64 Depends on libgtksourceview-3.0-common [ amd64 ] < 3.6.3-0ubuntu1 -> 3.8.2-0ubuntu1 > ( libs ) (< 3.7)
Broken gnome-pie:amd64 Depends on libbamf3-1 [ amd64 ] < 0.4.0daily13.06.19~13.04-0ubuntu1 > ( libs )
Broken libunity-core-6.0-5:amd64 Depends on unity-services [ amd64 ] < 7.0.0daily13.06.19~13.04-0ubuntu1 -> 7.1.2+13.10.20131014.1-0ubuntu1 > ( gnome ) (= 7.0.0daily13.06.19~13.04-0ubuntu1)
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-cirrus [ amd64 ] < 1:1.5.2+git20130108.e2bf5b25-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-intel [ amd64 ] < 2:2.99.904+git20131009.b9ad5b62-0ubuntu0sarvatt~raring > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau [ amd64 ] < 1:1.0.9+git20130730.300c5a32-0ubuntu0sarvatt~raring > ( x11 )
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-r128 [ amd64 ] < 6.9.1+git20130104.24f28a78-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-mach64 [ amd64 ] < 6.9.4+git20130104.80e62cc1-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-mach64:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-r128:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-cirrus:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-cirrus [ amd64 ] < 1:1.5.2+git20130108.e2bf5b25-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-intel [ amd64 ] < 2:2.99.904+git20131009.b9ad5b62-0ubuntu0sarvatt~raring > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau [ amd64 ] < 1:1.0.9+git20130730.300c5a32-0ubuntu0sarvatt~raring > ( x11 )
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-r128 [ amd64 ] < 6.9.1+git20130104.24f28a78-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-mach64 [ amd64 ] < 6.9.4+git20130104.80e62cc1-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-mach64:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-r128:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-cirrus:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-cirrus [ amd64 ] < 1:1.5.2+git20130108.e2bf5b25-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-r128 [ amd64 ] < 6.9.1+git20130104.24f28a78-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-mach64:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-r128:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-cirrus:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-cirrus [ amd64 ] < 1:1.5.2+git20130108.e2bf5b25-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-intel [ amd64 ] < 2:2.99.904+git20131009.b9ad5b62-0ubuntu0sarvatt~raring > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau [ amd64 ] < 1:1.0.9+git20130730.300c5a32-0ubuntu0sarvatt~raring > ( x11 )
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-r128 [ amd64 ] < 6.9.1+git20130104.24f28a78-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-mach64 [ amd64 ] < 6.9.4+git20130104.80e62cc1-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-mach64:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-r128:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-cirrus:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-cirrus [ amd64 ] < 1:1.5.2+git20130108.e2bf5b25-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-intel [ amd64 ] < 2:2.99.904+git20131009.b9ad5b62-0ubuntu0sarvatt~raring > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau [ amd64 ] < 1:1.0.9+git20130730.300c5a32-0ubuntu0sarvatt~raring > ( x11 )
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-r128 [ amd64 ] < 6.9.1+git20130104.24f28a78-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-mach64 [ amd64 ] < 6.9.4+git20130104.80e62cc1-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-mach64:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken libxi6:amd64 Breaks on xserver-xorg-core [ amd64 ] < 2:1.13.4~git20130508+server-1.13-branch.10c42f57-0ubuntu0ricotz~raring -> 2:1.14.3-3ubuntu2 > ( x11 ) (< 2:1.14)
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-mach64 [ amd64 ] < 6.9.4+git20130104.80e62cc1-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-r128:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-cirrus:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati [ amd64 ] < 1:7.1.99+git20130730.6a278369-0ubuntu0sarvatt~raring -> 1:7.2.0-0ubuntu10 > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-cirrus [ amd64 ] < 1:1.5.2+git20130108.e2bf5b25-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-intel [ amd64 ] < 2:2.99.904+git20131009.b9ad5b62-0ubuntu0sarvatt~raring > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau [ amd64 ] < 1:1.0.9+git20130730.300c5a32-0ubuntu0sarvatt~raring > ( x11 )
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-13 [ amd64 ] < none > ( none )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati [ amd64 ] < 1:7.1.99+git20130730.6a278369-0ubuntu0sarvatt~raring -> 1:7.2.0-0ubuntu10 > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-cirrus [ amd64 ] < 1:1.5.2+git20130108.e2bf5b25-0ubuntu0sarvatt > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-intel [ amd64 ] < 2:2.99.904+git20131009.b9ad5b62-0ubuntu0sarvatt~raring > ( x11 )
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau [ amd64 ] < 1:1.0.9+git20130730.300c5a32-0ubuntu0sarvatt~raring > ( x11 )

thats a lot of stuff ... do i have to remove them one by one ? will removing them cause any issue ? do i have to install them one by one again after the upgrade ?

EDIT: apparently it has something to do with AMD proprietary binaries ... i think

share|improve this question
    
Did you try apt-get install -f? –  arsaKasra Oct 18 '13 at 7:46
    
@arsaKasra yeah it said a bunch of packages were installed automatically and weren't needed so i removed them with -autoremove but still doesn't fix my problem... none of them were in the broken list –  MHB Oct 18 '13 at 13:56

2 Answers 2

up vote 3 down vote accepted

Try this:

 sudo apt-get install ppa-purge
 sudo ppa-purge xorg-edgers

See also this. It seems to be working for me, I'm in the middle of the upgrade.

share|improve this answer
    
thanks for the answer. unfortunately its too late for me :D i tried installing with live iso. it chose the upgrade option but then i got suspicious when it asked for a user name again, pressed back but my ubuntu was already gone. so i started from scratch –  MHB Oct 25 '13 at 6:03
    
that's a shame. I couldn't afford starting from scratch. All I had to do on my laptop was reinstalling bumblebee and adding Xubuntu as NX stopped working (like VNC, same problem) –  ZiglioNZ Oct 25 '13 at 23:30

As ZiglioNZ says, the first thing you need to do is remove the xorg-edgers repo:

sudo apt-get install ppa-purge
sudo ppa-purge xorg-edgers

One of my laptops worked after this. However on another laptop this didn't seem to fix the problem. Checking the log file /var/log/dist-upgrade/main.log I noticed that the error hadn't changed, I was still seeing a failure like:

2013-10-28 14:38:03,043 DEBUG Installing 'xserver-xorg-video-all' (Distro KeepInstalledPkgs rule)
2013-10-28 14:38:03,518 ERROR Dist-upgrade failed: 'E:Unable to correct problems, you have held broken packages.'

So I simply uninstalled the offending package and tried the upgrade again:

sudo apt-get remove xserver-xorg-video-all
sudo do-release-upgrade

and the upgrade was able to continue successfully this time.

Once the upgrade was complete, I then had a working system but apparently no X driver. So the first thing I did after login was add the xorg-edgers ppa back in and install the necessary driver:

sudo apt-add-repository ppa:xorg-edgers
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install nvidia-331
share|improve this answer
    
Glad you managed. So are you using native Nvidia drivers on a laptop? Do you have an optimus setup? have been using Bumblebee so far, but I hear Nvidia's standalone drivers are improving –  ZiglioNZ Jan 5 at 22:09
    
I have been using the xorg-edgers nvidia-331 drivers. I have a Quadro FX 770M so no Optimus as far as I know. –  joelittlejohn Jan 6 at 10:43
    
Be warned though the xorg-edgers nvidia-331 package is currently broken, and installing it will break your system (it just broke mine). After a lot of messing about, I basically did a complete reinstall and used the FOSS driver instead. –  joelittlejohn Jan 6 at 10:44
    
I use Nvidia drivers via Bumblebee. Although, I've never really used them because the laptop gets too hot and noisy and there are only a few games on Steam for Linux anyway. I was interested in trying stereoscopic 3D to improve my vision, but that doesn't work either, due to bloody optimus. So my hopes are with the next generation mobile GPUs, the new Tegra K1 and Ouya 2 and the likes –  ZiglioNZ Jan 6 at 22:39

protected by Community Mar 27 at 23:59

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.