Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have set up an ubuntu guest for Rails development in a Windows7-hosted virtual box. The windows workstation is a behind an extremely strict firewall with often fluctuating rules.

The ubuntu host seems to be unable to connect to hosts relying on SSL certificates.

The symptoms:

  • trying to connect to https://google.com via chrome brings up the "This site's security certificate is not trusted!" error. Same with Firefox.
  • trying to use curl with a secure site results in: curl: (60) SSL certificate problem, verufy that the CA cert is OK. Details: error: 14090086:SSL routines:SSL_GET_SERVER_CERTIFICATE:certificate verify failed
  • trying to install ruby gems fails with "... certificate verify failed ... error"

Any solutions, including instructions on how to diagnose this? I have tried adding certificated from

share|improve this question
Weird. Having the same issue yesterday and today after deciding to try this virtualbox setup. It's quite annoying but retrying bundle install a few times eventually worked –  jjfine Oct 19 '13 at 18:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.