Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Since upgrading to 13.10, I can't log in to unity desktop. Light dm works correctly, but attempting to log in tries to start the session then drops back to light. I've already dropped to terminal (ctrl+alt+f2) and done this:

sudo apt-get update

sudo apt-get install --reinstall ubuntu-desktop

sudo apt-get install unity

Logging in as a guest session also fails. Logging in to other window managers works with varying degrees of success.

Note: I have Cinnamon 2.0 installed from PPA.

I'm using a 2 monitor setup.

Also of note is that the session prior to my upgrade to 13.10 the background of unity failed to display at all, instead showing what was there in the screen buffer from the previous frame. The entire OS worked correctly otherwise though, so I just ignored it for the session. No other upgrades or even updates were done prior to this occurring.

My upgrade path to 13.10 was basically this: Install 13.04 alongside Windows 7, use ubuntu as a glorified web browser for a while, get updates (in preparation for 13.10), install 13.10.

I also used Unity Tweak Tool to change some aspects of unity, particularly auto-hide.

Any help or ideas would be appreciated, as I'm typing this on my phone :(

share|improve this question

marked as duplicate by Braiam, guntbert, Eric Carvalho, LiveWireBT, Seth Nov 4 '13 at 3:25

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
More information: Enlightenment doesn't work at all, drops back to light on login. Cinnamon seems to be working fine, but was throwing up errors relating to ubuntu-desktop the first time I started it. Doesn't seem to be doing that now. Gnome also seems OK as far as I can tell. No, actually, gnome also can't display a background, instead showing whatever was there on the previous frame. –  Sam Pearman Oct 18 '13 at 5:41
    
failed to load session "ubuntu" That's the error I receive when trying to log in. I managed to see it for long enough to read it by creating a new user account and trying to log in with that. –  Sam Pearman Oct 18 '13 at 5:45
    
I'm actually having this exact same issue, I know with me I can access other sessions, I had Cinnamon installed because I use Nemo, and I am using that for now. I also noticed that gnome-session-flashback was installed with the upgrade and that worked as well, just not Unity. –  KoRnKloWn Oct 18 '13 at 8:22
    
The best way to add additional information to your question is by editing it, with the edit button. It is better visible that way, and comments are mainly for secondary, temporary purposes. Comments are removed under a variety of circumstances. Anything important to your question should be in the question itself. –  guntbert Nov 2 '13 at 20:56
add comment

5 Answers 5

up vote 8 down vote accepted

After some research it seems to be that Unity in 13.10 has serious issues if Cinnamon 2.0 is installed. I don't have a full answer yet, but I at least have some more things to try now.

OK I found an answer! Unfortunately it means removing cinnamon entirely, but until it doesn't mess up unity I'll have to hold off.

sudo apt-get install ppa-purge
sudo apt-get purge --auto-remove cinnamon
sudo apt-get autoremove
sudo apt-get update -f
sudo apt-get dist-upgrade
sudo apt-get install ubuntu-desktop
sudo apt-get remove .*cinnamon.*
sudo apt-get remove .*nemo.*

Reboot and everything should be working! It's likely that not all of these steps are needed, but that's what I did to resolve the issue.

share|improve this answer
1  
OK, I did: sudo apt-get install ppa-purge sudo apt-get purge --auto-remove cinnamon sudo apt-get autoremove sudo apt-get update -f sudo apt-get dist-upgrade sudo apt-get install ubuntu-desktop which has removed Cinnamon, and now when I'm using Gnome Flashback the background renders correctly. Unity still not working though. –  Sam Pearman Oct 18 '13 at 10:00
    
Success! I examined a bit further using synaptic and found that some of the cinnamon packages were local. After looking at which ones they were, I came up with a simple regex to finish them off. sudo apt-get remove .*cinnamon.* sudo apt-get remove .*nemo.* (There was actually only one nemo package left for me though) One reboot later and I was able to start Unity without a hitch! I'll update the answer above. –  Sam Pearman Oct 18 '13 at 10:45
    
This worked perfectly for me. Thanks for all of the work. Sucks that cinnamon and 13.10 don't work together yet. –  Dan W Oct 20 '13 at 4:36
1  
Thank you. I was getting a bit desperate with this. Anyone seen a bug report for this? This is absolutely terrible issue, but is this Ubuntu or Cinnamon bug? As official (Ubuntu) repos do not have Cinnamon 2.0... –  pileofrocks Oct 20 '13 at 6:09
    
I have also Cinnamon installed and Unity does not work... but unluckily my wife is using it on the same PC, so I can't remove it... I hope someone will fix it... –  Pisu Oct 28 '13 at 6:59
show 1 more comment

FIX :

Start ubuntu and login

now in the blackscreen go to the terminal :

ctrl-alt-f1

type

nautilus  

and enter, error? no problem........ now type

unity   

and enter error? np now without exiting or stoping the unity comand return to the ubuntu interface
in my pc is ctrl-alt-f7 , then now you can open terminal:

ctrl-aLT-t

and type

nautilus

nautilus will open ( DO NOT CLOSE NAUTILUS ), now open another terminal without closing nautilus terminal, and type

sudo software-properties-gtk

search for graphic drivers .... my problem was the default drivers of X.org

I have an ati video card and I installed the drivers of fglrx-updates if you have nvidia install the drivers of nvidia or if you have ati install the one that i installed, then reboot

after login u will see nautilus running well and the wallpaper the only thing not working is unity...

open terminal and type:

dconf reset -f /org/compiz/
setsid unity

thats it.

I hope this fix your problem.

share|improve this answer
add comment

I had a similar problem. After the upgrade, no dash, no unity menu, only the desktop screen. All I could do was ctrl-alt-t for terminal or of course alt-f1 etc. I tried all of the fixes mentioned here and elsewhere without any change. Finally I ran the unity-tweak-tool --reset-unity and that didn't do anything (though I forgot to reboot). So I ran unity-tweak-tool from the terminal window and manually reset to default each of the setting screen. I then rebooted and now unity is running fine. I had tweaked somethings in 13.04, however I thought it wasn't much (icon package, some of the dash behaviors, touchpad behaviour). Hope this might help someone.

share|improve this answer
add comment

I had similar issue after installing cinnamon desktop, unity doesn't start.

Removed cinnamon completely and that's all, just logout no need to reboot.

share|improve this answer
add comment

I revived my Unity with these steps:

  1. Open a terminal, type: sudo apt-get purge alacarte caribou cinnamon cinnamon-bluetooth cinnamon-common cinnamon-control-center cinnamon-control-center-data cinnamon-desktop-data cinnamon-screensaver cinnamon-session cinnamon-settings-daemon cinnamon-translations cjs gir1.2-accountsservice-1.0 gir1.2-caribou-1.0 gir1.2-cinnamondesktop-3.0 gir1.2-clutter-1.0 gir1.2-cogl-1.0 gir1.2-coglpango-1.0 gir1.2-gkbd-3.0 gir1.2-gtkclutter-1.0 gir1.2-json-1.0 gir1.2-muffin-3.0 gir1.2-panelapplet-4.0 gir1.2-polkit-1.0 gir1.2-upowerglib-1.0 gir1.2-xkl-1.0 gnome-applets gnome-applets-data gnome-icon-theme-full gnome-media gnome-panel gnome-panel-data gnome-session-flashback gnome-themes-standard gnome-themes-standard-data gtk2-engines-pixbuf indicator-applet-complete libcaribou-common libcaribou0 libcinnamon-control-center1 libcinnamon-desktop0 libcjs0c libgnome-media-profiles-3.0-0 libmozjs185-1.0 libmuffin0 libnemo-extension1 libopencv-calib3d2.4 libopencv-contrib2.4 libopencv-core2.4 libopencv-features2d2.4 libopencv-flann2.4 libopencv-highgui2.4 libopencv-imgproc2.4 libopencv-legacy2.4 libopencv-ml2.4 libopencv-objdetect2.4 libopencv-photo2.4 libopencv-video2.4 libpanel-applet-4-0 libtbb2 mesa-utils metacity muffin-common nemo nemo-data nemo-fileroller notification-daemon python-opencv python-pyatspi

  2. After it is finished: sudo apt-get autoremove --purge

  3. After these, type: sudo apt-get install gnome-shell

  4. Restart, it will work from now on: you can log in to Unity by choosing on LightDM login screen.

share|improve this answer
    
Please shorten the package list, it's overly specific with version information and might remove packages also used by other packages. Removing just the right ones and catching the others with autoremove is the better way. –  LiveWireBT Nov 3 '13 at 8:33
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.