Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have upgrade to 13.10 recently. But, the brightness is working after I add this in version 13.04 before. After I upgrade to 13.10, this code is not working on ASUS Slimbook X401U

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

echo 0 > /sys/class/backlight/acpi_video0/brightness
exit 0
share|improve this question

3 Answers 3

You can change your brightness using xrandr like in this example.

sudo xrandr --output LVDS --brightness 0.3

Also you can try to switch to fglrx drivers and than switch back to the open source drivers. Switching between drivers in ubuntu unity is very easy. Just follow those steps in the UI: System Settings, Software and Updates, Additional Drivers.

share|improve this answer
    
The xrandr command are making my colors to look like sh***t so I decided to try it in another way. Please read my next answer below. –  Krasimir Popov Oct 29 '13 at 7:19

I wrote a sample script based on bash dialog, in order to change my laptop brightness until they fix that in 13.10.

Here above is the link to the source on github: https://github.com/kjpopov/Ubuntu-Useful-Scripts/blob/master/choose_brightness

You can edit it to add more values, and also you can change the line 33 to make it work for your video adapter.

I am using Asus X55U laptop with Radeon HD 6290

Make sure you execute the script as super user (root) privileges.

Best Regards!

share|improve this answer
    
Please do not post duplicate answers on different questions. It just creates more work for the moderators. If the questions are so similar that the same answer works on each, then the later of the two is likely a duplicate and should be flagged as such. –  RolandiXor Oct 31 '13 at 15:51

If you're using intel video card do:

sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf

Add the following in the empty file then log out and log in again or reboot. That should fix your problem.

Section "Device"
    Identifier  "card0"
    Driver      "intel"
    Option      "Backlight"  "intel_backlight"
    BusID       "PCI:0:2:0"

EndSection
share|improve this answer
    
I use AMD Radeon Graphics Card, not Intel. –  Daniel Yunus Jan 4 at 19:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.