Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I've upgraded to 13.10 and now I don't have the standard menu clock, which I need for work.

I checked and 'indicator-datetime' is installed. I even uninstalled/reinstalled that applet with no luck.

Also my "clock" settings under System Preferences are all disabled. I can't change anything.

Does anyone know how I can get the old menu clock back?

Alternatively is there another menu clock app I can download?

Edit 1

Thanks for the responses

  1. I've restarted several times and that didn't fix the issue.

  2. I just ran the 13.10 update today. But I ran it again a few minutes ago. I got about 200KB in random updates. The issue is still present after a reboot.

  3. # apt-cache policy indicator-datetime indicator-datetime: Installed: 13.10.0+13.10.20131016.2-0ubuntu1 Candidate: 13.10.0+13.10.20131016.2-0ubuntu1 Version table: *** 13.10.0+13.10.20131016.2-0ubuntu1 0 500 saucy/main amd64 Packages 100 /var/lib/dpkg/status

Edit 2

I believe the issue is related to 'rarings' changing the systray somehow...

Or systray disappeared, although I haven't got that solution to work yet.

Edit 3

Because of a suggestion from RolandiXor I've check the binaries. My system is missing '' but it has ''.

ldd /usr/lib/x86_64-linux-gnu/indicator-datetime-service => not found

Does anyone know how to get the binary that the datetime service needs but doesn't install?

share|improve this question
Are you sure you are up to date? Check the updater please. This bug should have been fixed already. – Seth Oct 18 '13 at 2:34
Can you add the output of apt-cache policy indicator-datetime? – Braiam Oct 18 '13 at 2:36
I have this same issue. I've found that doing a purge of indicator-datetime, reinstalling, and logging out will bring back the clock and all settings. However after one or two reboots the problem returns. – user207216 Oct 24 '13 at 18:39
Have you run indicator-datetime manually? (You can find its location on your system by running locate indicator-datetime). – RolandiXor Oct 31 '13 at 15:58
Just had the same issue with Ubuntu 14.04 LTS. Had to use killall unity-panel-service – Telmo Pimentel Mota Jun 12 '14 at 10:56

4 Answers 4

up vote 110 down vote accepted

There's a bug report for that in Launchpad.

Quick fix:
Open terminal (ctrl + alt + T) and type

killall unity-panel-service
share|improve this answer
Thanks, but I've restarted the computer many times. It's not a process restart issue. – kervin Oct 18 '13 at 19:14
Or you can just press "Alt+F2" and type the same and it will work. – Dustin Oct 25 '13 at 3:01
Marking as answer as it's probably what most readers will need. But for me it was a library loading path problem due to the fact that the datetime service seems to load from /usr/local before /usr for some reason. – kervin Nov 5 '13 at 17:43
This worked for me – Carlo Pires Jan 29 '14 at 0:24
Worked for me, but I need to do this again sometimes when I reboot – Isaac Betesh Feb 7 '14 at 13:45

I had the same problem. I performed a reboot and my clock is back.

share|improve this answer
Thanks, but I've restarted the computer many times. It's not a process restart issue. – kervin Oct 26 '13 at 21:04
killall unity-panel-service this worked like a charm for me ,no need for repoot :D – Yazan Rawashdeh Apr 14 at 8:44

Found the issue. I built a few libraries from source earlier in /usr/local/lib . indicator-datetime-service found those libraries before the system libraries in /usr/lib for some reason. It shouldn't have done that.

One of those libraries pulled in the old dependency which was no longer available. When I deleted all the GNOME/Evolution related libraries in /usr/local/lib I could start indicator-datetime-service again and my clock shown up.

So also try...

ldd --verbose /usr/lib/x86_64-linux-gnu/indicator-datetime-service

And look for any "not found" messages in the output. If you have a library dependency issue it will most likely show up in that output.

share|improve this answer
while that might have solved your specific issue, i tried that procedure and got no "not found"'s. is that because i ran that AFTER "fixing" the issue with the accepted answer? – tony gil Sep 26 '14 at 17:19
@kervin: Running this check on my Desktop 14.0.2 LTS (x86_64 with kernel v 3.16.0-41-generic) had the same results as that reported in the above comment. And I have not fixed anything yet, contrary to him. Would you care to elaborate on how to proceed on the "missing library" or PATH front ? I am stuck. Tx. – Cbhihe Jun 23 at 9:46
@kervin: File was no found because (perhaps in newer versions of the kernel) the path for that file is: /usr/lib/x86_64-linux-gnu/indicator-datetime/indicator-datetime-service ......... I don't know what is going on here. Any hint or help so I can further try to solve this hih¡ghly appreciated.. I am stuck. Tx. – Cbhihe Jun 23 at 10:00

I had the same problem, (no clock displayed and settings disabled) I had to select the default server for update in System Preferences. Reboot, and the clock was back.

share|improve this answer
It was likely just the reboot that fixed your issue. – Chev Oct 18 '14 at 18:20

protected by Community Nov 1 '13 at 16:59

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.