Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In order to get a working low-power video card setup I decided to use a custom xserver from Andrikos:ppa. It worked well, but when the official release caught up to the bug fixes I dried to drop the PPA packages and there are some of them I can not get rid of.

Packages were from here: https://launchpad.net/~andrikos/

I know how to down grade packages using Synaptic (Force Version...) and apt-get package=version. However, with some of the packages there are so many dependencies that is is no feasible to uninstall them all (as Synaptic wants to do).

This is what I would like to do:

sudo apt-get install -f libncurses5=5.9-10ubuntu4 libncursesw5=5.9-10ubuntu4 libncurses5:i386=5.9-10ubuntu4 libncursesw5:i386=5.9-10ubuntu4 libtinfo5=5.9-10ubuntu4 libtinfo5:386=5.9-10ubuntu4

But I get several hundreds of packages that have to be removed to meet the request. Does anyone have any tips on removing the PPA packages?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I think ppa-purge would solve your problem.

Install it:

sudo apt-get install ppa-purge  

Then run:

sudo ppa-purge ppa:andrikos/ppa
share|improve this answer
    
Thanks, worked like a charm! I did have to do sudo ppa-purge ppa:andrikos/ppa to get it to remove. Just for my information, is this application a script for existing apt-get functionality? If so, can I do the same operation without ppa-purge? –  CodePoet Oct 19 '13 at 1:38
    
@CodePoet Hmm. I'm not sure. I'll do a little research on that. I fixed the command in the answer so that someone else won't have the same problem :) –  Seth Oct 19 '13 at 1:43
1  
@CodePoet Yes, the whole thing is one big (well, rather big) bash script. You can take a look here. So technically you could do the same on your own, although someone obviously thought it was too much work since they wrote this ;) –  Seth Oct 19 '13 at 1:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.