Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded to the latest version (13.10). I have it running on an old laptop. Since the upgrade, whenever I close the laptop lid, it goes to sleep mode.

Any idea on how to fix?

I've tried the solution here:

Keep Ubuntu Server running on a laptop with the lid closed?

After installing acpi-support I don't have the file: /etc/acpi/event/lidbtn to edit.

Your help is appreciated!

share|improve this question
    
after i read your question, i checked my system settings. in ubuntu 13.04 in system settings - power i had chosen 'when lid is closed do nothing' but now, after the upgrade to 13.10 it is changed in 'when lid is closed suspend'. so i think you have to change it manually. –  user85164 Oct 17 '13 at 23:47

2 Answers 2

up vote 23 down vote accepted

I've had the same problem and after a lot of reading, I realized that Ubuntu 13.10 uses systemd-logind and it handles the lid close event. To disable entering the sleep mode edit the /etc/systemd/logind.conf file and uncomment/modify/add the line:

HandleLidSwitch=ignore

Then execute sudo restart systemd-logind or simply reboot.

This has solved the problem on my PC.

share|improve this answer
    
That was it. Thank you! –  user203846 Oct 18 '13 at 20:45
    
I get Unknown job: systemd-logind... –  spartacus Nov 13 '13 at 15:06
    
Are you running Ubuntu 13.10? –  jeremija Nov 13 '13 at 19:18
    
switching this line to HandleLidSwitch=hibernate brought back the 13.04 functionality –  Iain Ballard Feb 10 at 21:23
    
+1. Still works nicely on 14.04 as well. –  Ward Muylaert Aug 2 at 14:10

after i read your question, i checked my system settings. in ubuntu 13.04 in system settings - power i had chosen 'when lid is closed do nothing' but now, after the upgrade to 13.10 it is changed in 'when lid is closed suspend'. so i think you have to change it manually

enter image description here

share|improve this answer
1  
I think the OP is running Ubuntu Server, tho, since they refer to a link for "Ubuntu Server". If they don't have a GUI then they won't be able to get to this screen. @user203846 - Can you clarify this by editing the question title? –  tudor Oct 18 '13 at 0:33
    
It is running server. I have update/clarified the title. Thanks! –  user203846 Oct 18 '13 at 19:08
    
I'm on 13.10 with a Dell Latitude e6430 and these settings don't appear to make a real difference. On battery power is suspends every time the list is closed. –  Miles Oct 21 '13 at 14:53

protected by Community Oct 27 '13 at 18:57

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.