Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Is there any way to reset the System Settings Control Panel page?

The Control Panel was fine, but the for no apparent reason, PRIVACY, BACKGROUND and a host of other icons have vanished...

My system seems pretty messed up after the upgrade... Shutdown, Reset, and Logout from the menu no longer work either...

Settings with, presumably, icons missing

However, I can launch the Privacy panel from the terminal:

activity-log-manager

and it runs... so why is this, and others, now missing from the System Setting Control Panel?

I have checked and: activity-log-manager-control-center is installed

Is there a config file I can check, or a setting in Gconf where the list of icons are referenced?

I have run - in desperation -

sudo apt-get purge unity*
sudo apt-get purge ubuntu*
sudo apt-get autoremove

Run Gconf-cleaner and Janitor

then re-installed all packages

Still the same issue....?

share|improve this question
    
Related, though not necessarily a duplicate (different icons missing): System Settings icons missing in 14.04 –  Eliah Kagan Aug 17 at 16:12

4 Answers 4

I had this problem with Xubuntu. I restored the icons in the settings manager by editing the .desktop files in ~.local/share/applications/ and changing

Hidden=true 

to

Hidden=false
share|improve this answer

Here's what worked for me with the same issue. Run sudo apt-get update in a terminal. In my case, this did not successfully complete but it did recommend to run dpkg and specified the exact commandline command to run.

This appeared (a best guess) to complete some of the steps that may not have been properly completed within the upgrade process itself. After this there were no missing icons and everything appears to be as expected. Hope this helps!

share|improve this answer
    
I have the same problem. Your suggestion did not apply to my system. –  Andreas J. Nov 18 '13 at 21:17
up vote 0 down vote accepted

I could not find a solution. In the end I backed up and did a fresh install. All working fine after that.

share|improve this answer

I know this is an old post, but in case this happens again try running:

sudo apt-get install unity-control-center

it worked for me when I ran into a similar issue

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.