Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just upgraded to Ubuntu 13.10 and I'm seeing a strange behaviour. All windows I open have a black, boxy border, including popups, as you can see in the provided image. (The black box in the bottom right is a terminal, which fails to display any text. However, I can enter commands and they execute.) I followed the steps in this post: How do I reset my Unity configuration? to reset Unity using the unity-tweak-tool. Although helpful, that did not fix the issue. I'm thinking this may be a graphics card driver issue.

Any help is much appreciated.

Black Borders, black terminal to the bottom right

share|improve this question
    
I'm experiencing a similar issue, but it seems to go away if I Alt+Tab a few times, but it comes back eventually. Are you using an nVidia card? –  elclanrs Oct 18 '13 at 0:22
    
Sadly I don't see any changes when alt-tabbing. The graphics specs for this laptop read as: Intel® HD Graphics - 1 GB NVIDIA® OptimusTM Graphics Technology, so I'd say yes. –  Eric Oct 18 '13 at 0:33

2 Answers 2

up vote 6 down vote accepted

I had the same problem. I fixed it by installing Mir, following these instructions:

https://wiki.ubuntu.com/Mir/Installing

I had to use XTerm because Terminal was all black.

share|improve this answer
    
That did it. Thanks very much. –  Eric Oct 24 '13 at 0:09
    
Didn't work for me. I only have an Intel HD graphics and not the hybrid nvidia one...but nothing. I did an upgrade instead of a clean install, and that has to be the problem. i just can't figure out where the issue is. I have reset unity and compiz and nothing. it is as if the window decorator is gone, though i know it is there because i can move, close the windows (by guessing the location). :( –  semi-newbie Oct 25 '13 at 14:22

I was able to fix the black borders in Ubuntu 13.10 with the commands below. Although I did not have problems with terminal not showing text.

Reset compiz settings:

dconf reset -f /org/compiz/

Then restart Unity:

setsid unity

(Source)

share|improve this answer
    
Nope didn't work for me. –  w00t Jan 9 at 17:31
    
It worked for me in Ubuntu 14.04 –  jplandrain Apr 30 at 14:14

protected by Community Oct 22 '13 at 9:30

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.