Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I made an automatic update on my Ubuntu 13.10 (from 13.04) system today. Since this point of time, I am in really big trouble. I use a VNC server with Gnome classic, after the update my Gnome was gone. So i tried everything. Checked the xstartup file of vncserver.

Right now I reached a point where I can't find the answer. The logfile says that gnome-session-fallback is missing, even directly after I installed it with apt-get (tried it serveral times, installing, uninstalling and so on).

I have no chance to use it as you can see in this terminal copy:

root@ip-xxx:~/.vnc# apt-get install gnome-session-fallback
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  gnome-session-fallback
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/2,914 B of archives.
After this operation, 247 kB of additional disk space will be used.
Selecting previously unselected package gnome-session-fallback.
(Reading database ... 210977 files and directories currently installed.)
Unpacking gnome-session-fallback (from .../gnome-session-fallback_1%3a3.6.2-0ubuntu15_all.deb) ...
Setting up gnome-session-fallback (1:3.6.2-0ubuntu15) ...

root@ip-xxx:~/.vnc# gnome-session-fallback
The program 'gnome-session-fallback' is currently not installed. You can install it by typing:
apt-get install gnome-session-fallback

If you have some idea, please give me a hint...

Thank you!

share|improve this question
add comment

4 Answers 4

I needed the graphical interface, so I removed everything from Gnome and installed KDE. I added the line

startkde &

in my .vnc/xtstartup file. Now the graphical interface with VNC works again. KDE starts with a crash, but it seems to run. I will try to find out where the crash happens.

share|improve this answer
add comment

gnome-session-fallback is a transitional package, which causes gnome-system-flashback to be installed. It actually is installed, but the bash suggestion tool doesn't know about the change, so it keeps suggesting that you install it.

As to your actual problem, there are several related questions posted here on AU, but none of them have a real solution (as of 10/22/2013):

share|improve this answer
add comment

It looks like the script /usr/bin/gnome-session-fallback is missing from the package.

On 13.04 the script has the following two lines:

#! /bin/sh
exec gnome-session --session gnome-fallback "$@"

You may try to create this script yourself and see if that solves the problem.

share|improve this answer
add comment

Alternatively you might install xfce4 desktop and enjoy a neat and full-featured evnironment through VNC, provided you add a line "startxfce4 &" in ".vnc/xstartup" file. The line "exec x11/xinit/xinitrc" should be hashed instead.

I experienced similar inconvenience and since gnome-session simply does not work I decided so switch to xfce4. No bugs, no hassle. Just fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.