Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm was actually trying to install Debian Wheezy (which failed horribly), then tried Ubuntu Server 13.04 and got the exact same problems as w/ Debian: After installing, the system doesn't show any boot-selection and tells me "Missing operating system".

My setup is pretty simple:

  • /dev/sdc - 1TB HDD (+ 3 other NTFS HDD)
  • /dev/sdc1 - EFI, 100MiB, bootable
  • /dev/sdc4 - ext4, 65GiB, Ubuntu/Debian (sdc2 & 3 are NTFS w/ data. Sorta lacking SATA-ports, therefore no OS-only HDD/SSD)

Grub seems to be installed on /dev/sdc4, /dev/sdc1 only contains a "EFI"-folder. Not sure if thats correct.

I used UNetbootin on OS X to make an 8GB USB-drive bootable and used the standard amd64-iso, running a perl-script wich eradicates a couple of naming-errors (different story). Using this tutorial and actually disabling UEFI and using legacy only dind't work either, the usb drive dind't even bother to boot.

I'm pretty clueless here. I'd just like to install and use either Debian or Ubuntu Server!

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Knowing more about your setup may be helpful. In particular, you mention using OS X to prepare your boot medium, but you also don't mention any OS X partitions, so it's not clear if the computer is a Mac or some other type of computer. If it's a Mac, I recommend you post back with clarifications, including whether you've actually got an OS X installation on this system. If it's a UEFI-based PC, one of the following will probably get things up and running:

  • If Secure Boot is enabled on your computer, disable it. Then download and prepare a USB flash drive or CD-R with my rEFInd boot manager. (Note that there are download links for images of both type.) Boot with it. This should get Linux booting. You can then install the Debian-package version of rEFInd, which should take over the boot manager duties on your computer.
  • Run the Boot Repair utility from an emergency disc booted in EFI mode. In many cases, this will get GRUB working again. In case it doesn't, be sure to record the URL that the program presents. You can then post it here, since it will hold additional details that may be of use in diagnosing your problem.

If you've got a Mac, rEFInd is likely to be the more useful tool, but you should install it from OS X, not from Linux. (That is, don't use the Debian package; use the .zip file from OS X.)

share|improve this answer
    
Thanks for your response! The computer's a custom built machine, though I have to prepare the boot media on my Mac. On the PC, there doesn't seem to be an option to disable Secure Boot, only to explicitly disable UEFI and use Legacy only (Asus P8H61-I LX R2.0). With UEFI disabled, the USB drive doesn't boot. With both Legacy and UEFI enabled, however, rEFInd doesn't recognize any OS. Gonna try out Boot Repair. –  user1004816 Oct 18 '13 at 7:21
1  
Solved the issue, thank you so much! I had to select "Legacy only"/"Disable UEFI" for the install via CD, since the USB drive wouldn't boot w/o UEFI. After that, I used the bootable Version of Boot Repair to fix GRUB2. Now everyhing runs like a charme (at least sorta)! –  user1004816 Oct 18 '13 at 18:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.