Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded my 64 bit Lubuntu to 13.10 on my netbook today. After the upgrade, I simply can't autostart the xfce4 power manager. I tried to add from the desktop session settings, I tried to copy the power manager.desktop file to ~/.config/autostart folder.

Everything looks fine. Then I logout, log back in and the darn power manager just won't start automatically. It only starts when I double click the icon, or if I start it from the terminal.

share|improve this question
    
I tried to autostart Firefox, that's not working either, so the prblem is with the autostart, not with the specific app. –  user203766 Oct 18 '13 at 9:27
    

7 Answers 7

Check ~/.config/lxsession/Lubuntu/desktop.conf.

Look for laptop_mode and see that it's set to 'yes':

[State]
laptop_mode=yes

This worked for me at least. Mine was set to 'no' so I would have to start xfce4-power-manager manually. By changing the value to 'yes' it now starts at login automatically without any further configuration.

share|improve this answer
1  
Just wanted to say that this worked for me in 13.10. –  GateKiller Dec 14 '13 at 8:57

Either:

  1. Open Preferences → Default applications for LXSession.
  2. Go to the autostart tab.
  3. Change the option "Disable autostarted applications" from config-only to no.

Or similarly:

  1. Edit ~/.config/lxsession/Lubuntu/desktop.conf
  2. Change the following line under [Session]
  3. Change

    disable_autostart=config-only
    

    to this instead:

    disable_autostart=no
    
share|improve this answer
    
Very nice! Is there any documentation? I didn't come across any for "Default applications for LXSession". –  user25656 Oct 19 '13 at 8:13
    
Also see lists.ubuntu.com/archives/lubuntu-users/2013-September/… –  user25656 Oct 19 '13 at 11:36
    
Yes, it's more safe to use UX instead of editing files manually! And to understand what's happening behind the scene in parallel! –  Augustin Riedinger Mar 27 at 11:36

Sometimes, for some applications it can be useful to instead of starting them directly, to use a script which delays the starting of the program.

Create a file like this;

#!/bin/bash
sleep 10
xfce-power-manager

And save it as powermanagerautostart.sh somewhere safe, I use a folder called /home/shane/scripts.

Then instead of adding xfce-power-manager to desktop session settings, add

bash /home/username/scripts/powermanagerautostart.sh

This may fix your problem.

share|improve this answer
    
I tried it, I made that script, I executed it, it works. After that I realized, that I can't add a script like that to desktop session settings in an LXDE environment, like in gnome. So I made a .desktop file /,that launches the script/, in the ~/.config/autostart folder. Than I double clicked the .desktop file, an it brought up the xfce4 power manager. But after I logged out, and logged back in, it still does NOT work automatically :( –  user203766 Oct 17 '13 at 22:21
  1. create a file .starter in your home dir and make it executable
  2. in that file write command: cairo-dock, save and close
  3. edit file: sudo leafpad /etc/xdg/lxsession/Lubuntu/autostart
  4. add this new line: @/home/user/.starter #user is you
  5. save and close
  6. reboot and it shall now run automaticaly

p.s. sorry I am talking about autostarting cairo, but same procedure should work for you, you only have to know the starting command. same way I start dropbox, conky, compton in lubuntu 13.10

share|improve this answer

I edited ~/.config/lxsession/Lubuntu/desktop.conf and changed the following line under [Session] from :

disable_autostart=config-only

to this instead:

disable_autostart=no

Worked for me on my netbook as suggested by MrQuade.

share|improve this answer

In lubuntu not working xfce4 power manager:

  1. uninstall xfce4 power manager (optional)
  2. install gnome-power-manager
  3. Desktop session setting enable (Demonio de configuración de Gnome)(Gnome settings daemon)
  4. Dconf editor org/gnome/settings-daemon/plugins/power (modify at will)

the problem I found is that when you activate the gnome daemon status bar could not put it on transparent

Fix it with dconf / org / gnome / desktop / bakground (off draw-background)

sorry for my English

share|improve this answer

xfce4-power-manager not started, applet not visible

Delete > Desktop configuration file:

/etc/xdg/autostart/xfce4-power-manager.desktop

Settings Manager / Session and Startup / Startup Applications

Item disabled:

Energy Management (power Management Xfce environment)

New item enabled with new command:

Mame:          Xfce Power Manager (For example-Your name)
Description:   Power manager startup
Command:       xfce4-power-manager --no-daemon

http://ubuntuset.url.ph/power_manager.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.