Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install Ubuntu 13.10 on my vaio pro in UEFI mode but it failed (i.e. when I reboot, Ubuntu is not detected). So I installed boot-repair in a live session and used the recommended repair (here is the output of boot-repair http://paste.ubuntu.com/6251374/) but nothing changed.

Do you have any idea to solve my problem?

share|improve this question

6 Answers 6

up vote 4 down vote accepted

I have Xubuntu 13.10 running on my Vaio Pro. I ran boot-repair from the LiveCD and managed to get the grub menu, though Xubuntu wouldn't boot. After some research, I discovered this page:

http://www.nicksplace.com.au/2013/07/04/fedora-19-on-vaio-pro-13-ssd-issues/

Its no secret that the Vaio Pro comes with a very nice SSD. The 128GB version is a MZHPU128HCGM made by Samsung. From my benchmarking it is very fast with ~1100MB/s read and ~500MB/s write. But when booting into Fedora 19, it may fail to boot, or the system may lock up for short periods (especially under heavy IO). During boot it may show a stream of the following messages (if it happens while you are logged in they will be in dmesg):

01:45:25,494 ERR kernel:[  155.668632] ata1.00: exception Emask 0x0 SAct 0x3 SErr 0x0 action 0x6 frozen
01:45:25,494 ERR kernel:[  155.668640] ata1.00: failed command: READ FPDMA QUEUED
01:45:25,494 ERR kernel:[  155.668650] ata1.00: cmd 60/08:00:00:08:00/00:00:00:00:00/40 tag 0 ncq 4096 in
01:45:25,494 ERR kernel:[  155.668650]          res 40/00:01:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
01:45:25,494 ERR kernel:[  155.668655] ata1.00: status: { DRDY }
01:45:25,494 ERR kernel:[  155.668659] ata1.00: failed command: READ FPDMA QUEUED
01:45:25,494 ERR kernel:[  155.668667] ata1.00: cmd 60/08:08:80:b8:e7/00:00:0e:00:00/40 tag 1 ncq 4096 in
01:45:25,494 ERR kernel:[  155.668667]          res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
01:45:25,494 ERR kernel:[  155.668672] ata1.00: status: { DRDY }

From my previous experience with the errors on other systems I decided to try disabling Native Command Queuing (NCQ). This immediately fixed the issue.

To make the fix permanent you need to add libata.force=noncq to your GRUB2 default kernel boot parameters. As root, edit /etc/defaults/grub and add libata.force=noncq to the end of the GRUB_CMDLINE_LINUX line. The finished file should look similar to the below:

GRUB_TIMEOUT=2
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rd.md=0 rd.lvm=0 rd.dm=0 vconsole.keymap=us $([ -x /usr/sbin/rhcrashkernel-param ] && /usr/sbin/rhcrashkernel-param || :) rd.luks=0 vconsole.font=latarcyrheb-sun16 rhgb quiet libata.force=noncq"
GRUB_DISABLE_RECOVERY="true"

Then simply update your GRUB2 menu and reboot:

grub2-mkconfig -o /boot/efi/EFI/Boot/grub.cfg

I am very interested to know if anyone has experienced this issue on their Vaio Pro or whether there is an issue with my SSD.

So, I edited the grub list after booting from the LiveCD using:

sudo nano /etc/default/grub

I then changed this line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

To look like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash libata.force=noncq"

And then I ran:

sudo update-grub
share|improve this answer
    
Thanks a lot, it solved my problems. The linked blog contains a lot of interesting stuff to put linux on a vaio pro. –  Thomash Oct 21 '13 at 11:00
    
link now broken –  Tshepang Jan 7 at 22:40
    
I just posted the Google Cached version of the page, thanks for the heads up. –  Ben Jan 8 at 2:45

SONY VAIO’s UEFI firmware seems to kick only “EFI/Microsoft/Boot/bootmgfw.efi” however you put other efi files into EFI partition(ex: by using BootRepair). Other efi binaries are never called. You need to replace the binary “EFI/Microsoft/Boot/bootmgfw.efi” with refind boot manager.

Please see also: http://www.slideshare.net/slideshow/embed_code/27418512

share|improve this answer

i too struggled with EFI and finally gave up. but then i decided to try it again, for my reinstall.

here's a nice summary of things to do, to make ubuntu work on the vaio pro: http://steffankarger.nl/2013/12/10/ubuntu-13-10-on-the-sony-vaio-pro-13/

share|improve this answer
    
Thanks for the link. Please include the most important steps from that link into this answer, probably part of the "Convince the Sony firmware to fire up Grub" section. –  landroni May 8 at 3:56

I may be missing something, but your Boot Repair output looks correct to me, so it should be working. I therefore suspect you may have a firmware bug. Check with Sony to see if there's an update to your firmware, and if so, install it. You might then need to run Boot Repair again.

If that fails, try running Boot Repair a third time, but this time, click the Advanced options and select the option to back up and replace the Windows boot loader. This will put a copy of GRUB in its place, which is a very ugly (but sometimes necessary) hackish workaround for EFI bugs.

share|improve this answer

Disable SecureBoot and run Boot-Repair again. if any issue, indicate the new URL.

share|improve this answer

After more than a month hunting after solutions for ubuntu 14.04 on my new viao pro, this is what worked for me, simple and elegant: http://ubuntuforums.org/showthread.php?t=2227580

I did have to add the "quiet splash libata.force=noncq" to the grub, as suggested above.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.