Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I having difficulty setting up pidgin to work with my company's microsoft 365's communicator lync 2013 (not 2010) account.

I either receive a message stating authentication failed, or Incompatible authentication scheme chosen: NTLM depending upon the user agent values used from this wiki

It appears that both the user agent values that start with UCCAPI provide authentication failed error, which I'm guessing is "closer" to the solution.

I have triple checked that the password is correct.

Below are some images of my settings (I have changed the company name to "company" for annonymity.

enter image description here enter image description here

I am running pidgin with a script in order to fix a write error issue:

export NSS_SSL_CBC_RANDOM_IV=0
pidgin -d

I am also using the latest version of SIPE (1.10.1) by using this ppa: https://launchpad.net/~aavelar/+archive/ppa

What settings do I need to change/add to get it to work?

share|improve this question
1  
Did you try using the full user agent string? UCCAPI/15.0.4420.1017 OC/15.0.4420.1017 (Microsoft Lync) –  mason81 Oct 30 '13 at 12:58
    
My company switched over to use Office 365 and I needed to adjust some settings, I found the information here to be helpful: vincentpassaro.com/2013/02/01/… –  mason81 Mar 18 at 15:15

4 Answers 4

I manged to get this working on Ubuntu 12.04 with the pidgin (2.10.3) and pidgin-sipe (1.11.2-1ubuntu1) installed from the default precise/universe repo. We are using Lync2013 also.

I did use an environment variable to run pidgin. Without this pidgin would fail every time with a 'Read failed'. This was configured in /home/myuser/.profile by appending:

export NSS_SSL_CBC_RANDOM_IV=0

Check here for more information about why this variable is needed for sipe.

The sipe settings were as follows

'Basic' tab:

  • Username: my email as used within the company (e.g john.smith@company.co.uk)
  • Login: company logon domain\username (e.g COMPANY\john.smith)

Advanced tab:

  • Connections type: Auto
  • User Agent: UCCAPI/15.0.4420.1017 OC/15.0.4420.1017 (Microsoft Lync)
  • Use Single Sign-on: [ticked]

All other fields in Advanced were blank. I had no proxy configured.

share|improve this answer

I was able to get this working on ubuntu 13.04 (question asked on ubuntu 12.04). Here are a few pointers:

Use the full user agent string as @mason81 pointed out:

UCCAPI/15.0.4420.1017 OC/15.0.4420.1017 (Microsoft Lync)

I did not need to use a startup script to solve any write errors. e.g.

export NSS_SSL_CBC_RANDOM_IV=0
pidgin -d

That linked repo was pointless on this distro, don't use it. It appears that on Ubuntu 13.04 you will install pidgin-sipe 1.13.3-1 by default which is an even more up-to-date version.

It appears that the pidgin/sipe setup I have installed here has a third authentication type for TLS as seen in this picture which is what I needed. enter image description here


For reference, here are my connection settings that are working: enter image description here enter image description here

The other tabs are the defaults


Update

To get this working in ubuntu 14.04, do exactly the same, but untick the single sign on!

share|improve this answer
    
Thanks for the update for 14.04 -- I finally got around to upgrading and then couldn't connect to lync and it was driving me crazy! –  mason81 yesterday

You can use Pidgin, the universal chat client, with the third party Pidgin Lync plugin as a Lync client for Linux. Check this guide.

share|improve this answer
2  
This answer makes no sense, as the question already states that I was using the pidgin client with the SIPE addon. "I am also using the latest version of SIPE (1.10.1)..." –  Programster Feb 17 at 12:15

For reference: I first got Pidgin/SIPE working on Ubuntu following Programster's instructions. I then tried on Windows and it failed with an error message

Web ticket request to https://webpoolams0e08.infra.lync.com:443/CertProv/CertProvisioningService.svc failed

Unticking SSO, again according to Programster's, instructions solved that. Only problem now is that no names are visible for my Lync contacts. If I mouse over they a "tool tip" with the name appear but the name remain invisible when the mouse is not there.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.