Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I get these errors trying to run tor with vidalia

Apr 19 21:55:15.371 [Notice] Tor v0.2.1.30. This is experimental software. Do not rely on it for strong anonymity. (Running on Linux i686)
Apr 19 21:55:15.372 [Notice] Initialized libevent version 1.4.13-stable using method epoll. Good.
Apr 19 21:55:15.373 [Notice] Opening Socks listener on 127.0.0.1:9050
Apr 19 21:55:15.373 [Warning] Could not bind to 127.0.0.1:9050: Address already in use. Is Tor already running?
Apr 19 21:55:15.373 [Warning] Failed to parse/validate config: Failed to bind one of the listener ports.
Apr 19 21:55:15.373 [Error] Reading config failed--see warnings above.

I don't think tor is running. Here is a nmap scan of my localhost

Starting Nmap 5.21 ( http://nmap.org ) at 2011-04-19 21:59 CEST
Nmap scan report for localhost (127.0.0.1)
Host is up (0.0000050s latency).
Hostname localhost resolves to 2 IPs. Only scanned 127.0.0.1
rDNS record for 127.0.0.1: localhost.localdomain
Not shown: 989 closed ports
PORT      STATE SERVICE
22/tcp    open  ssh
53/tcp    open  domain
80/tcp    open  http
139/tcp   open  netbios-ssn
445/tcp   open  microsoft-ds
631/tcp   open  ipp
3128/tcp  open  squid-http
3306/tcp  open  mysql
9000/tcp  open  cslistener
9050/tcp  open  tor-socks
10000/tcp open  snet-sensor-mgmt

I see tor-socks is running here, probably be the cause of the problem. How do I stop this from starting up? I want to use vidalia so I can monitor whats going on.

share|improve this question
add comment

5 Answers

up vote 6 down vote accepted

Newer versions of Tor have a file /etc/default/tor.vidalia. It contains three lines:

if [ -x /usr/bin/vidalia ]; then
        RUN_DAEMON=yes
fi

You can change the option to no. This will prevent from starting as daemon. Instead Tor will now start when you start Vidalia.

share|improve this answer
add comment

I believe this answer (found here ) can be useful. You'll probably have to start from scratch and download the bundle. It has worked for me. The bundle can be found here.

share|improve this answer
1  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Peachy Sep 18 '12 at 11:40
add comment

My solution to this problem was that TOR daemon was already running which Vidalia didnt like.

ps aux | grep tor

Followed by a

sudo service tor stop

Or a

sudo killall tor

Then starting vidalia produced no error.

I think also adding qbi's tor.vidalia file to start a daemon also helped.

share|improve this answer
add comment

try this:

Go to Settings > Advanced > Tor Control and checked Use TCP Connection (ControlPort) with the address 127.0.0.1:9051 .

For me worked fine

share|improve this answer
add comment

I think the condition is unnecessary. If you look in /etc/default/tor the tor.vidalia file is not sourced unless that same test passes.

This snipit solved part of my problem, but not all of them, so, DISCLAIMER: I still don't have a working setup.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.