Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running a Dell Inspiron 1501

I use Linux only. No Microsoft or Apple operating systems (or really anything closed-source). I've only been using Linux for a little over a year but I'm starting to gain a comfortable level of familiarity with the system and terminology.

I've been having some issues with Quantel Quetzal and Raring Ringtail, especially with older hardware, so I opted to install Ubuntu 12.04.3 Precise Pangolin on the Inspiron 1501. I checked my MD5 sum after downloading my ISO and all was good. I have in fact used this iso/dvd to install Precise Pangolin successfully on a few other systems (some of which are even older than this laptop).

Install goes fine. The wireless card doesn't work out of the box but this is a known issue which is fairly easy to fix. So, first thing I did was open up a terminal and run

sudo apt-get update && sudo apt-get upgrade

which, part way through, crashed (I assume lightdm and possibly X) and took me to a black screen filled with white lines of text that were either errors or just the ouputs of commands. The reason I say that is because I was unable to gleam any useful information from the output on the screen. I did take a picture however and will post a link.

After that, every time I boot the system it goes right to that black screen posting all the error messages or output in white text. I never get a purple Ubuntu splash, so from what I can tell after reading this wiki article:

That means that after the kernel is selected, it is unable to correctly implement the settings it needs. If the purple splash never shows, the frame buffer was never set correctly right? This leads me to believe that it could be a kernel issue? The wiki suggested to try and pinpoint the issue by rolling back kernels until I find one that works. Is this my best option? I think I'm going to give it a try anyways and will let everyone know if I am able to solve the issue this way.

I have since done a few reinstalls and some trouble-shooting including a couple hours scouring the net for anyone with any kind of similar issue. Most of the issues I could find involved getting a black screen after login and none of them said anything about any information output on this black screen.

My reinstalls have taught me that there is no issue updating, but as soon as I run

sudo apt-get upgrade

my system goes to the black screen and every time I boot it up it does the same thing. The only way to fix is by reinstall. I never get any ability to log in. After a hard power off to the laptop (because I cannot use ctrl+alt+del to reboot) when it boots again it goes to the grub boot menu and I can select between regular boot, recovery mode and the two memtest options. I never tried the memtest options but the other two both lead to the same black screen.

Some people having a black/blank screen issue claim to have fixed it by using 12.10 or 13.04 but I believe they were having a different issue where they got a black/blank screen after logging in. I think I will still give these images a try, but mostly figured I would just wait another day or two for 13.10.

Other things I figured I would try from the following three articles:

After logging in, there's a black screen and my cursor, nothing else! in Ubuntu 12.10

Black Screen on Login

After Upgrading to 12.04 I can't get to the login screen

include opening a terminal using ctrl+alt+f1 and trying a variety of reseting unity, x settings, lightdm (or switching to gdm); but I doubt this will work or that I will even be able to access a terminal. I'm pretty sure the whole system is stuck after it loads the last line on the black screen.

I will try these things and post more information when I have. Hopefully someone has an idea in the meantime and I will keep checking back trying to find a solution. Thank you.

Here are 3 different pictures of the error message. I had to take with my phone:

share|improve this question
So I was not able to get into a console from ctrl+alt+f1 so I pretty much have a frozen system. I did notice that the error occurs during the upgrade while it says something about no current kernel detected and that it's deciding to build a new kernel. It starts to do this in the console and goes to the black screen. – Ibuntu Oct 17 '13 at 15:26
I tried installing Ubuntu 13.04 and as soon as I restarted it went to a similar black screen with different errors. I link to the picture below. I never got logged in to Ubuntu 13.04. I also downloaded 12.10 and low and behold, it works and I can update and upgrade with no issues. Ubuntu 13.10 just came out today and even though 12.10 works, I will give 13.10 a try and if it doesn't I will just roll back to 12.10. Will let everyone know how this works. Here is the error from 13.04: – Ibuntu Oct 17 '13 at 15:32
up vote 0 down vote accepted

After lots of rigorous searching I was able to discover someone else having the same problem who realized that the Dell Inspiron 1501, although mostly advertised as a 64-bit laptop with a 64-bit processor (and all of my research confirmed the processor to be 64-bit, but I guess I never looked as hard as I should have), was in fact not fully 64-bit capable and there was a missing 32-bit package in (all but 12.10) the Ubuntu installation that breaks the kernel image... or something.

But I remember for sure that it's a missing 32-bit dependency and does something to the kernel.

So I was able to solve this issue by installing a 32-bit version of Ubuntu.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.