Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had a DVD drive and a external hard drive connected to my PC and I've disconnected them accidentally. Now I've already spent hours trying to access them, mount, umount and can't figure how to connect the devices again. Can't believe how such a simple thing can be such a headache in linux I can see the directory where the devices were mounted previously, but a there is nothing inside them. Can anyone help me out? I'm new to Linux and I'm finding this very frustrating at the moment.


share|improve this question
up vote 0 down vote accepted

Reboot the machine and check once

if its not solved

Check mount /dev/sr0 /media

Did your External Drive was in ext4 file system or its a NTFS ?

share|improve this answer
Hard drive in NTFS. When trying to mount /dev/sr0 I get the error wrong fs type, bad option, bad superblock on /dev/sr0 – J.B Oct 16 '13 at 12:48
After a few restarts it's working again. I haven't tried the Hard Drive yet but it is not important for now. I can ftp instead. Tks for replying – J.B Oct 16 '13 at 12:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.