Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Not sure why but I can only copy text from Tomboy notes to Gedit and then re-highlight and copy in to the app I need the text in.

I am guessing this is a simple issue of config and not a real problem.

Any help greatly appreciated.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Start up Tomboy Notes, Go to Help>About

This will tell you what version you are using. I'm using version 1.4.2 on Ubuntu 10.10 Maverick AMD 64Bit and I can highlight and right click to copy, and I can right click and paste into any other program. I can also do a CTRL C to copy and Ctrl V to paste using keyboard shortcuts with no problems.

I have tested this on a Netbook Acer One Inspire running Ubuntu 10.04 i32bit. On an HP Pavillion with Ubuntu 10.10 i32bit, and on a Compaq Presario CQ62 running 10.10 64 bit amd version. Tested on Evolution mail, Thunderbird, LibreOffice Writer, OpenOffice Writer, Gedit. No problems.

Unfortunately, the formatting is lost with Tomboy and Gnote when pasting to other applications. (Gnote is the same program but ported to C+++ and a bit faster.)

SOLUTION: You could however, export your note as an HTML file, Save it to your desktop or folder, then open it with Firefox, copy and paste to any application and this will preserve the formatting of the original note.

To do this open a note with Tomboy, click on the tool icon (gear looking icon), and select Export to HTML.

You can also go to Edit>Preferences>Add-ins. There are many addins for this program. The only thing that is very cryptic is that you need to click on the tool icon on an open note to see the print menu.

This is important in case you need to Back up your notes.

Your notes are just a simple xml format files. They are kept in a hidden folder under your home folder. In Ubuntu Hidden folders start with a period. To see them you need to enable it under the View Menu or do CTRL H. Once you know this, it is very easy to backup your notes. :-)

.local/share/tomboy

Click Places, Click Home Folder, Click View, Click Show Hidden Files, double click .local folder, double click share folder, double click tomboy folder.

Just copy your tomboy folder and paste a copy of it for safe keeping.

You can also use other apps to see your notes. Navigate to the hidden folder .local/share/tomboy Right click on a note, select open with other application, REMEBER TO REMOVE the check-mark that says to, "Remember this application for "application/x-note type" files. You can choose, a web browser, LibreOffice Writer, Gedit etc. to see the note, with fancy xml tags.

share|improve this answer
    
Thanks for the reply. I am running Tomboy 1.4.2 on Ubuntu 10.10 32bit. Unfortunately I could not use the rest of your advise to fix my problem. Any ideas why I can only copy in to certain other apps and not all of them? –  AFD Apr 20 '11 at 12:55
    
After further investigating this issue it seems that Thunderbird didn't want to paste the text with the formatting that Tomboy had made. In Thunderbird I went to Edit>Paste Without Formatting and it copied the text without the hyperlinks/bolding that were in the Tomboy note. –  AFD Apr 20 '11 at 15:21
    
I have spruced up my original answer. Maybe try re-installing Tomboy, back-up your notes, then go to Ubuntu Software centre, and remove Tomboy,then re-install it. –  Merlin2525 Apr 23 '11 at 3:09
    
Check your software Sources, make sure you are getting your updates from the Main Server. I have had issues in the past, with weird errors, and they have disappeared once I set it to Main Server ie. Canonical. I know that when Ubuntu gets installed it chooses the servers that are closer to where one lives. –  Merlin2525 Apr 23 '11 at 3:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.