Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded to 11.04 beta 2 and everything works just like clockwork, but now I’ve run into multi screen issues :/ at first it worked but then a installed the proprietary drivers (I think this is causing it) and now its coming up with this virtual size restrictions and only lets me mirror screen or use just one. its like its limiting me on how much total resolution I can have if you get what I mean. I hope there’s a work around for this... this is what is says when I try enable my second monitor.

The selected configuration for displays could not be applied required virtual size does not fit available size: requested=(2646, 1024), minimum=(320, 200), maximum=(1366,1366)

share|improve this question
    
Welcome to Ask Ubuntu! Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding more detail? askubuntu.com/questions/14008/… –  Jorge Castro Apr 22 '11 at 23:07
    
Also, if Valorin's answer works for you, please accept it. You even get a badge as a reward! :) –  Josh Glover Aug 16 '11 at 6:48
add comment

4 Answers

I had the same problem on my Dell with an ATI graphics card.

But then I noticed that ATI have their own graphics driver configuration tools which you can use to set the monitors up. The process I did was:

  1. Opened the "ATI Catalyst Control Center (Administrative)"
  2. Clicked on "Display Manager" in the left tree menu
  3. On the right under "Multi-Display", selected "Multi-Display desktop with display(s) x" in the drop down
  4. Dragged the monitors in the display to the right locations for my monitor layout
  5. Clicked Apply, confirmed the change, and rebooted my computer

It then rebooted and came with using both monitors.

Assuming you have ATI graphics drivers, that should work for you. If you have NVidia, there should be an NVidia control panel you can use to do similar.

Try this if the above doesn't work Open the Catalyst Control using command line by typing: gksudo amdcccle

share|improve this answer
1  
This didn't work for my Radeon HD with Oneiric :( same error, but the Catalyst config don't do the trick. –  jesusiniesta Oct 23 '11 at 11:15
add comment

You have to configure X for a larger virtual desktop.

Edit your /etc/X11/xorg.conf file, and inside the "Screen" section, add the following lines:

Subsection "Display"
    Virtual 2646 1024
EndSubsection

Where the numbers for Virtual are the ones marked "requested" in the error message:

The selected configuration for displays could not be applied
required virtual size does not fit available size: 
requested=(2646, 1024), minimum=(320, 200), maximum=(1366,1366)
           ^^^^  ^^^^

If there is already a Subsection "Display", don't create another. Just add Virtual 2646 1024 to the end of the existing Subsection.

Log out and back in (to restart the X server) and you should be good to go.

share|improve this answer
    
This doesn't seem to work on Ubuntu 13.04 –  Crimbo Jun 23 '13 at 17:33
add comment

It should work, but in 11.10 Catalyst seems not to be saving the setting, so it just reverts without ever stretching the desktop.

share|improve this answer
add comment

For me this was fixed by simply switching the two monitor cables around (at graphics card) - I was doing that in the display control centre (when enabling the second monitor) and it didn't like it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.