Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm completely new to linux and ubuntu and have gotten in over my head very badly. I want to dual boot windows 7 and ubuntu, so I had a fresh install of windows 7, everything worked fine, then I followed directions to install ubuntu in the proper way to dual boot, but since then, I have been unable to get windows to work at all. From the grub page, if I try to run windows normally, it says it's inaccessible due to a recent software change. If I run the recovery, it starts to run, it loads all the files, takes me to a grey background screen, sits for a couple seconds, then my computer restarts. I tried using a windows 7 recovery disk and that got me nowhere, with a message that said "No drives were found. Click load to provide a mass storage driver for installation" (If I click load, it says "To install the device driver needed to access your hard drive, insert the installation media containing the driver files, and then click ok").

I tried using boot-repair, I did the common repair and that changed nothing, but here is the link it gave me if this helps Also, in boot-repair, I tried the advanced options>Other options>"Repair Windows Boot Files" but I can't click it, it's just greyed out.

I would try the

    bootrec.exe /fixboot


    bootrec.exe /fixmbr

as suggested many places online, but I can't get any sort of dialogue box on the windows recovery disk I made. I'm really beyond my knowledge and have been trying different things for about 6 hours now with no success at all. I think maybe I messed up the partitioning when I installed ubuntu, but I really don't know anything about that. Here's what it looks like now, after being ripped apart trying to fix things based on other info online and error messages

I'll do my best to provide any other information needed to solve this, but try to put it in idiot terms as best as possible for me.

share|improve this question

Using Windows 7 Installation Disk Boot the PC and While u getting to the Installation screen choose repair and choose the Command line and use command fixmbr and fixboot then reboot the machine , it will fix , and if u need the Ubuntu 13.04 too u need to Write ur Grub once more

share|improve this answer

Based on your partition table, I'd say you have wiped out your Windows installation. You have a roughly 10 GB NTFS partition, but Windows 7 64 bit requires 20 GB of disk space.

I think you should start from scratch:

  1. Re-install Windows 7 from CD
  2. Shrink the Windows partition
  3. Install Ubuntu (to new partitions)

It seems that you have MBR partition tables, so you need one primary partition for the grub bootloader and /boot partition. You already have three primary partitions (the max) in use, so I'm not sure how to solve it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.