Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently, I have installed Ubuntu on my Acer Aspire Notebook. Everything works flawlessly, except for the graphics card. For example when I try to watch movies they run at a much lower frame rate than in Windows. I suspect the system is running in VGA mode.

Therefore I checked the boot options with cat /proc/cmdline, and it seems nomodeset is activated. However, if I try to remove that, the Display turns off.

share|improve this question
    
What version of Ubuntu are you running? If you're running 13.04 as tagged, then your Intel graphics card should work perfectly fine without any additional driver! How exactly are you watching the movies? What application are you using, what codecs do these movies have? Etc. –  gertvdijk Oct 16 '13 at 8:17
    
Usually I am using VLC but I have also tried totem. One of the films I tried is encoded with H.264/MPEG-4, another one with MPEG-1/2 Video. The first film, is recognised, but runs with a low frame rate. The second one, however, does not work at all. –  user203053 Oct 16 '13 at 12:10
1  
Please verify your VA-API settings. See askubuntu.com/a/247922/88802 –  gertvdijk Oct 16 '13 at 14:51
    
@gertvdijk I tried it, but it seems not to work. –  user203053 Oct 16 '13 at 21:57
    
What exactly do you mean by "seems not to work"? Does VA-API not work or does it, but doesn't it solve your primary issue? Please be more specific and edit your question to include this information instead of posting comments. That is how this Q&A site works. It's not a discussion forum, you see? –  gertvdijk Oct 16 '13 at 22:05
add comment

1 Answer

up vote 1 down vote accepted

Finally I have found the problem, and solved it. The problem was apparently that the monitor backlight was completely switched off. Until now I have used the Bootoption nomodeset to prevent it. However, I just had to add the following boot options instead:

acpi_backlight=vendor acpi_osi=Linux video.use_bios_initial_backlight=0
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.