Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Was sitting here working on the computer when the power restarted for some reason. When my computer rebooted and I signed back in my top and side panel are missing. All the rest of my desktop seems to be there. I opened a terminal and entered the command:


I got the message:

xfce4-panel: there is already and instance running

yet neither of my panels are showing up. I have tried logging out and logging back in several times and still no panel. I'm running Xubuntu 12.04 64-bit.

share|improve this question
Try these once.. sudo dpkg-reconfigure xfce4-panel If it doesn't help then try to re-install it by: sudo apt-get -f install --reinstall xfce4-panel. Logoff and log-in and see what happens.. Reply.. – Saurav Kumar Oct 15 '13 at 20:36
First command did nothing. Ran the second command, logged off, logged in. Now my panels are showing but my desktop isn't. – Jason Smith Oct 15 '13 at 21:07
What do you mean by your desktop? Run these commands once and restart your system. 1.sudo dpkg-reconfigure $(sudo dpkg -l | grep xfce | awk '{print $2}' | tr '\n' ' ') 2. sudo update-initramfs -u – Saurav Kumar Oct 15 '13 at 21:13
All the folders, files, icons on my desktop are gone. All that is showing is the default screen from the login session. – Jason Smith Oct 15 '13 at 21:19
are you able to open the terminal using ctrl+alt+t. If still not then you can switch to tty1 CLI mode any time by pressing ctrl+alt+F1. Then you can execute commands that I've mentioned. You can also logout any time you want by : sudo pkill -u smith if smith is your user name.. Reply.. – Saurav Kumar Oct 15 '13 at 21:22

Re-installing xfce4-panel would solve this issue

Follow these steps to re-install and re-configure xfce4-panel. Open terminal and execute these commands:

sudo apt-get update
sudo apt-get -f install --reinstall xfce4-panel

Be sure that you don't remove other packages while installing. Check the installation message carefully.

Once installed execute following command to re-configure xfce:

sudo dpkg-reconfigure $(sudo dpkg -l | grep xfce | awk '{print $2}' | tr '\n' ' ')
sudo update-initramfs -u

Then reboot your system.

share|improve this answer

I had the same problem. I tried the answer from Saurav, but that did not work for me.

My panel would never show when I logged in. So I followed the instructions from this page:

These are the steps that I got it going:

1) Press ALT-F2.
2) Type "xfce4-panel" and press return.  This brings up the Xcfe panel.
3) Log out of Xfce and tick the "Save session for future logins" button.

Worked for me.

share|improve this answer

I had this problem after I changed graphics drivers. My solution was:

1) Press ALT-F2

2) Type "xfce4-panel --preferences" and press return. This brings up the panel preferences.

3) Under "Output", make sure that it is selected to show up on the right monitor. It might be selected to show up on an external video output or some other non-existing monitor.

4) Repeat this for all affected panels by selecting them from the pulldown at the top of the panel preferences window.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.