Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently moved some files from ntfs to ext4 in my external disk. I am not able to run executable files after I convert it to ext4.

  1. Below is the fstab entry I use to mount the ext4 partition.

    UUID={UUID} {path} ext4 rw,async,suid,dev,exec,user 1 1
    
  2. Below is the permission for the file I am trying to run

    -rwxrwxrwx 1 {myid} {myid} 73015 Oct  9 09:38 eclipse
    
  3. When I try to run the program from command line, I get following error message bash: ./eclipse: Permission denied

  4. When I try to run the program from Nautilus, I get a message that 'There is no application installed for executable files'.

  5. I checked the permissions tab in the file properties and the 'Allow executing file as program' bit is set.

share|improve this question
    
Close voters: why is this no reproducible? This question has all the information needed to reproduce the problem and is already answered. –  Braiam Oct 17 '13 at 1:28
add comment

1 Answer

up vote 4 down vote accepted

The issue got resolved by changing the mount option from 'user' to 'nouser'. I have not idea why though...

share|improve this answer
1  
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  qbi Oct 16 '13 at 18:58
1  
@qbi why not? Care to explain? –  Braiam Oct 16 '13 at 19:59
    
@qbi I posted it as an answer because that was the solution for my issue. By changing the fstab option, I am able to run the executable from the external disk. –  Srik Oct 16 '13 at 20:24
    
This solution works. Please mark it as accepted answer. since ext4 rw,async,suid,dev,exec,nouser is equivalent to defaults, you can directly write it as UUID={UUID} {path} ext4 defaults 1 1 –  mac Nov 3 '13 at 5:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.